maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Lundberg (JIRA)" <j...@codehaus.org>
Subject [jira] (MSITE-634) Invalid links to sub-modules when specifying site url using a profile
Date Mon, 02 Apr 2012 19:55:02 GMT

    [ https://jira.codehaus.org/browse/MSITE-634?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=295595#comment-295595
] 

Dennis Lundberg commented on MSITE-634:
---------------------------------------

The Site Plugin uses the value of the <url> element in the POMs, to create relative
links. I don't see any such element in the samples you provided. Note that I'm not talking
about <distributionManagement>/<site>/<url>.

You can read more at:
http://maven.apache.org/plugins/maven-site-plugin-2.3/faq.html#Use_of_url
                
> Invalid links to sub-modules when specifying site url using a profile
> ---------------------------------------------------------------------
>
>                 Key: MSITE-634
>                 URL: https://jira.codehaus.org/browse/MSITE-634
>             Project: Maven 2.x and 3.x Site Plugin
>          Issue Type: Bug
>          Components: multi module, relative links
>    Affects Versions: 2.3
>            Reporter: Matthias Henkel
>         Attachments: childpom.xml
>
>
> When using a profile for specifying the site url the links to the sub-modules get broken.
> {code}
> <?xml version="1.0" encoding="UTF-8"?>
> <project xmlns="http://maven.apache.org/POM/4.0.0" 
>    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
>    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
> 	<modelVersion>4.0.0</modelVersion>
> 	<groupId>com.company.application</groupId>
> 	<artifactId>application</artifactId>
> 	<packaging>pom</packaging>
> 	<version>04.00.02-9_19-SNAPSHOT</version>
> 	<name>application</name>
> 	<prerequisites>
> 		<maven>2.2.1</maven>
> 	</prerequisites>
> 	<build>
> 		<pluginManagement>
> 			<plugins>
> 				<plugin>
> 					<groupId>org.apache.maven.plugins</groupId>
> 					<artifactId>maven-site-plugin</artifactId>
> 					<version>2.3</version>
> 				</plugin>
> 			</plugins>
> 		</pluginManagement>
> 	</build>
> 	<profiles>
> 		<profile>
> 			<id>company</id>
> 			<distributionManagement>
> 				<site>
> 					<id>application.site</id>
> 					<url>scpexe://projects.company.com/srv/filestore/application/site/siteFixing/</url>
> 				</site>
> 			</distributionManagement>
> 		</profile>
> 	</profiles>
> 	<modules>
> 		<module>com.company.application.module</module>
> 	</modules>
> </project>
> {code}
> Executed command: {{mvn clean site-deploy -P company}}
> Reproducible with: {{maven-site-plugin}} {{2.3}} but not with {{2.2}}.
> When specifying the {{distributionManagement}} section outside of a profile everything
works fine.
> The site of the parent module is deployed to https://projects.company.com/application/filestore/site/siteFixing/index.html
but the link to the sub-module points to https://projects.company.com/module/index.html even
though the sub-module has been deployed to https://projects.company.com/application/filestore/site/siteFixing/module/index.html
.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message