maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabriele Catania (JIRA)" <j...@codehaus.org>
Subject [jira] (MECLIPSE-719) to-maven mojo does not handle source bundles correctly
Date Fri, 13 Apr 2012 08:59:02 GMT

    [ https://jira.codehaus.org/browse/MECLIPSE-719?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=296397#comment-296397
] 

Gabriele Catania edited comment on MECLIPSE-719 at 4/13/12 3:57 AM:
--------------------------------------------------------------------

I reworked my previous patch (method layout, source formatting etc), I am attaching the following:

# {{MECLIPSE-719}}{{.patch}} svn diff output of proposed patch and unit tests on {{EclipseToMavenMojo}}
# {{build-pre-patch.log}} build output of eclipse:to-maven with the current eclipse plugin
on an eclipse 3.4 sdk directory
# {{build-post-patch.log}} build output of eclipse:to-maven with the patched eclipse plugin
on an eclipse 3.4 sdk directory

the command I executed to produce the two outputs is:
{noformat}
mvn -e -X org.apache.maven.plugins:maven-eclipse-plugin:2.9:to-maven -DeclipseDir=.
{noformat}

(Please discard the first upload of {{MECLIPSE-719}}{{.patch}} since it contains incorrect
formatting of the unit tests file)
                
      was (Author: gcatania):
    I reworked my previous patch (method layout, source formatting etc), I am attaching the
following:

# {{MECLIPSE-719}}{{.patch}} svn diff output of proposed patch and unit tests on {{EclipseToMavenMojo}}
# {{build-pre-patch.log}} build output of eclipse:to-maven with the current eclipse plugin
on an eclipse 3.4 sdk directory
# {{build-post-patch.log}} build output of eclipse:to-maven with the patched eclipse plugin
on an eclipse 3.4 sdk directory

the command I executed to produce the two outputs is:
{noformat}
mvn -e -X org.apache.maven.plugins:maven-eclipse-plugin:2.9:to-maven -DeclipseDir=.
{noformat}
                  
> to-maven mojo does not handle source bundles correctly
> ------------------------------------------------------
>
>                 Key: MECLIPSE-719
>                 URL: https://jira.codehaus.org/browse/MECLIPSE-719
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>    Affects Versions: 2.9
>         Environment: Any eclipse SDK version
>            Reporter: Gabriele Catania
>            Priority: Minor
>         Attachments: build-post-patch.log, build-pre-patch.log, handle-sources.patch,
MECLIPSE-719.patch, MECLIPSE-719.patch
>
>
> the to-maven mojo does not install source bundles according to maven conventions. For
example, the following plugins:
> # {{org.eclipse.osgi_3.4.3.R34x_v20081215-1030.jar}}
> # {{org.eclipse.osgi.source_3.4.3.R34x_v20081215-1030.jar}}
> should be deployed respectively to:
> # {{M2_REPO/org/eclipse/osgi/3.4.3-R34x_v20081215-1030/osgi-3.4.3-R34x_v20081215-1030.jar}}
> # {{M2_REPO/org/eclipse/osgi/3.4.3-R34x_v20081215-1030/osgi-3.4.3-R34x_v20081215-1030-sources.jar}}
> instead, they are deployed here:
> # {{M2_REPO/org/eclipse/osgi/3.4.3-R34x_v20081215-1030/osgi-3.4.3-R34x_v20081215-1030.jar}}
> # {{M2_REPO/org/eclipse/osgi/}}{color:red}{{source/}}{color}{{3.4.3-R34x_v20081215-1030/}}{color:red}{{source}}{color}{{-3.4.3-R34x_v20081215-1030.jar}}
> To test this behaviour, I downloaded an eclipse sdk and ran the to-maven mojo in its
unpacked installation directory
> I am attaching a quick patch I devised to set the "sources" classifier on plugins whose
name ends with ".source". I tried to minimize code changes, a revised implementation should
probably modify {{createGroupId()}} and {{createArtifactId()}}, and avoid installing the pom
for the sources jar.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message