maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philippe Marschall (JIRA)" <j...@codehaus.org>
Subject [jira] (MRAR-29) Make ra.xml optional - 1.6 spec
Date Fri, 07 Sep 2012 13:23:21 GMT

     [ https://jira.codehaus.org/browse/MRAR-29?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Philippe Marschall updated MRAR-29:
-----------------------------------

    Attachment: maven-rar-plugin.patch

This patch fixes it in a similar way to the Maven WAR Plugin. Instead of a servlet-version
the WAR Plugin uses {{failOnMissingWebXml}}. I assume this is because even if you're on Servlet
3 you still may want to use {{web.xml}}. The same is true for JCA. So I introduced {{warnOnMissingRaXml}}.
                
> Make ra.xml optional - 1.6 spec
> -------------------------------
>
>                 Key: MRAR-29
>                 URL: https://jira.codehaus.org/browse/MRAR-29
>             Project: Maven 2.x Rar Plugin
>          Issue Type: New Feature
>    Affects Versions: 2.3
>            Reporter: Kresimir Kovac
>         Attachments: maven-rar-plugin.patch
>
>
> According to Java EE Connector Architecture Specification 1.6 Deployment Descriptor is
not Optional.
> Most of the Resource Adapter can be configured using only annotations.
> maven-rar-plugin should not enforce mandatory ra.xml deployment descriptor any more or
it should 
> include new parameter 'jca-version' and behave accordingly.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message