maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bakito (JIRA)" <j...@codehaus.org>
Subject [jira] (MDEP-380) copy-dependencies should be able to use the artifact's baseVersion
Date Wed, 03 Oct 2012 06:56:35 GMT
Bakito created MDEP-380:
---------------------------

             Summary: copy-dependencies should be able to use the artifact's baseVersion
                 Key: MDEP-380
                 URL: https://jira.codehaus.org/browse/MDEP-380
             Project: Maven 2.x Dependency Plugin
          Issue Type: New Feature
          Components: copy-dependencies
    Affects Versions: 2.5.1
            Reporter: Bakito
         Attachments: maven-dependency-plugin.patch

It should be possible to copy dependencies with their baseVersion.
Currently the version used for snapshots is the resolvedVersion (timestamped version) org.apache.maven.artifact.DefaultArtifact.setResolvedVersion(String)
which may be the timestamped snapshot version. 
When calling copy-dependencies I expect snapshots to have the snapshot version org.apache.maven.artifact.DefaultArtifact.getBaseVersion().

The attached patch introduces a new parameter 'useBaseVersion' which, if selected, sets the
base version in the copied artifact's names.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message