maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Goldhahn (JIRA)" <j...@codehaus.org>
Subject [jira] (MSITE-657) Site of sub-project is uploaded to wrong location
Date Thu, 04 Oct 2012 14:09:35 GMT
Martin Goldhahn created MSITE-657:
-------------------------------------

             Summary: Site of sub-project is uploaded to wrong location
                 Key: MSITE-657
                 URL: https://jira.codehaus.org/browse/MSITE-657
             Project: Maven 2.x and 3.x Site Plugin
          Issue Type: Bug
          Components: site:deploy
    Affects Versions: 3.0
         Environment: Apache Maven 3.0.4 (r1232337; 2012-01-17 09:44:56+0100)
Java version: 1.7.0_03, vendor: Oracle Corporation
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"

            Reporter: Martin Goldhahn
         Attachments: parent-pom-master-ed097fe.tar.gz, soa-parent-pom-e1a864a.tar.gz

My parent pom no.uis:paren-pom has site.xml defined. Now I have another pom no.uis.service:parent-pom
that uses the first as parent. In both I have a site deployment descriptor like this:
{code}
  <distributionManagement>
    <site>
      <id>source01.uis.no</id>
      <url>dav:https://source01.uis.no/maven-site/${project.groupId}/${project.artifactId}/${project.version}</url>
    </site>
  </distributionManagement>
{code}

But when I upload the second project's site, it is uploaded to {{https://source01.uis.no/maven-site/no.uis/no.uis.service/parent-pom/1.1.1}}
instead of {{https://source01.uis.no/maven-site/no.uis.service/parent-pom/1.1.1}}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message