maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Lundberg (JIRA)" <j...@codehaus.org>
Subject [jira] (MASSEMBLY-324) DependencySet scope runtime includes jars that are scope provided
Date Fri, 02 Nov 2012 10:47:13 GMT

     [ https://jira.codehaus.org/browse/MASSEMBLY-324?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dennis Lundberg updated MASSEMBLY-324:
--------------------------------------

    Component/s: dependencySet
    
> DependencySet scope runtime includes jars that are scope provided
> -----------------------------------------------------------------
>
>                 Key: MASSEMBLY-324
>                 URL: https://jira.codehaus.org/browse/MASSEMBLY-324
>             Project: Maven 2.x Assembly Plugin
>          Issue Type: Bug
>          Components: dependencySet
>    Affects Versions: 2.2-beta-2
>            Reporter: Michael Mattox
>
> I use some jars in provided scope:
> {code:xml}
> 		<dependency>
> 			<groupId>javax.servlet</groupId>
> 			<artifactId>servlet-api</artifactId>
> 			<version>2.5</version>
> 			<scope>provided</scope>
> 		</dependency>
> {code}
> in my assembly, I specify scope as runtime:
> {code:xml}
> 		<dependencySet>
> 			<outputDirectory>WEB-INF/lib</outputDirectory>
> 			<unpack>false</unpack>
> 			<scope>runtime</scope>
> 		</dependencySet>
> {code}
> Yet I still find the servlet-api-2.5.jar in my WAR.  SInce the servlet-api is scope provided,
it should be provided by the container and not included in the WAR.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message