maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@codehaus.org>
Subject [jira] (MENFORCER-147) RequireSamePluginVersions
Date Tue, 29 Jan 2013 18:00:17 GMT
Robert Scholte created MENFORCER-147:
----------------------------------------

             Summary: RequireSamePluginVersions
                 Key: MENFORCER-147
                 URL: https://jira.codehaus.org/browse/MENFORCER-147
             Project: Maven 2.x Enforcer Plugin
          Issue Type: New Feature
          Components: Standard Rules
    Affects Versions: 1.2
            Reporter: Robert Scholte


When plugins are specified as both a build plugin and a reporting plugin, their versions should
be the same. This way it is not required to introduce another property just to keep these
versions in sync.
Add several predefined plugins, which versions should match.
For instance: maven-surefire-plugin, maven-failsafe-plugin, maven-surefire-report-plugin.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message