maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnaud Heritier (JIRA)" <j...@codehaus.org>
Subject [jira] (MASSEMBLY-643) descriptorSourceDirectory: parameter isn't used
Date Thu, 31 Jan 2013 14:11:13 GMT
Arnaud Heritier created MASSEMBLY-643:
-----------------------------------------

             Summary: descriptorSourceDirectory: parameter isn't used
                 Key: MASSEMBLY-643
                 URL: https://jira.codehaus.org/browse/MASSEMBLY-643
             Project: Maven 2.x Assembly Plugin
          Issue Type: Bug
    Affects Versions: 2.4
            Reporter: Arnaud Heritier


I configure the plugin with something like this :
{code}
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-assembly-plugin</artifactId>
        <configuration>
          <descriptors>
            <descriptor>plf-standalone-enterprise-tomcat-distribution-content.xml</descriptor>
          </descriptors>
<descriptorSourceDirectory>src/main/assemblies</descriptorSourceDirectory>
        </configuration>
      </plugin>
{code}
But it doesn't find the descriptor (using its filename or its ID)
{code}
[DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-assembly-plugin:2.4:single' with
basic configurator -->
....
[DEBUG]   (s) descriptorSourceDirectory = /Users/arnaud/Code/eXo/platform-distributions/plf-enterprise-tomcat-standalone/src/main/assemblies
[DEBUG]   (s) descriptors = [plf-standalone-enterprise-tomcat-distribution-content.xml]
....
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.4:single (plf-standalone-tomcat-distribution-content)
on project plf-enterprise-tomcat-standalone: Error reading assemblies: Error locating assembly
descriptor: plf-standalone-enterprise-tomcat-distribution-content.xml
[ERROR] 
[ERROR] [1] [INFO] Searching for file location: /Users/arnaud/Code/eXo/platform-distributions/plf-enterprise-tomcat-standalone/plf-standalone-enterprise-tomcat-distribution-content.xml
[ERROR] 
[ERROR] [2] [INFO] File: /Users/arnaud/Code/eXo/platform-distributions/plf-enterprise-tomcat-standalone/plf-standalone-enterprise-tomcat-distribution-content.xml
does not exist.
[ERROR] 
[ERROR] [3] [INFO] File: /Users/arnaud/Code/eXo/platform-distributions/plf-enterprise-tomcat-standalone/plf-standalone-enterprise-tomcat-distribution-content.xml
does not exist.
{code}
I simplified the config (I'll need to create an it) in my case i was using a 2nd assembly
coming from the classpath


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message