maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@codehaus.org>
Subject [jira] (ARCHETYPE-442) Maven keeps connecting to http://repo1.maven.org even with mirrors
Date Sun, 02 Jun 2013 13:10:03 GMT

     [ https://jira.codehaus.org/browse/ARCHETYPE-442?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte closed ARCHETYPE-442.
------------------------------------

    Resolution: Duplicate
      Assignee: Robert Scholte

Due to the {{[DEBUG] Searching for remote catalog: ...}} I'm pretty sure you're talking about
the {{maven-archetype-plugin}}.
Closing as duplicate of ARCHETYPE-358
                
> Maven keeps connecting to http://repo1.maven.org even with mirrors
> ------------------------------------------------------------------
>
>                 Key: ARCHETYPE-442
>                 URL: https://jira.codehaus.org/browse/ARCHETYPE-442
>             Project: Maven Archetype
>          Issue Type: Bug
>         Environment: Apache Maven 3.0.4 (r1232337; 2012-01-17 08:44:56+0000)
> Maven home: C:\Program Files\apache-maven-3.0.4
> Java version: 1.6.0_22, vendor: Sun Microsystems Inc.
> Java home: C:\Progra~1\Java\jdk1.6.0_22\jre
> Default locale: pt_PT, platform encoding: Cp1252
> OS name: "windows server 2008 r2", version: "6.1", arch: "amd64", family: "windows"
>            Reporter: Rafael Pato
>            Assignee: Robert Scholte
>            Priority: Critical
>         Attachments: settings.xml
>
>
> I created a mirror in setting.xml , for every connection , to connect to my local repo
in Artifactory . It works! But when the generate action starts Maven connects to http://repo1.maven.org:
> {code}
> <!-- ***** BEFORE THE GENERATE, MAVEN USES MIRROR ********* -->
> [DEBUG] Using mirror ibiblio.org (http://localhost:8081/artifactory/remote-widesys-libs)
for central (http://localhost:8081/artifactory/remote-widesys-libs).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for snapshots (http://localhost:8081/artifactory/remote-widesys-libs).
> [DEBUG] Extension realms for project org.apache.maven:standalone-pom:pom:1: (none)
> [DEBUG] Looking up lifecyle mappings for packaging pom from ClassRealm[plexus.core, parent:
null]
> [DEBUG] Resolving plugin prefix archetype from [org.apache.maven.plugins, org.codehaus.mojo]
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for apache.snapshots (http://repository.apache.org/snapshots).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for apache.snapshots (http://repository.apache.org/snapshots).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for apache.snapshots (http://repository.apache.org/snapshots).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for apache.snapshots (http://repository.apache.org/snapshots).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for codehaus.org (http://snapshots.repository.codehaus.org).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for apache.snapshots (http://repository.apache.org/snapshots).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository).
> [DEBUG] Using mirror remote-widesys-libs (http://localhost:8081/artifactory/remote-widesys-libs)
for apache.snapshots (http://repository.apache.org/snapshots).
> <!-- ***** AFTER THE GENERATE, MAVEN DOESN'T USE MIRROR ********* -->
> [INFO] Generating project in Batch mode
> [DEBUG] Searching for remote catalog: http://repo1.maven.org/maven2/archetype-catalog.xml
> [DEBUG] Searching for remote catalog: http://repo1.maven.org/maven2
> {code}
> And btw, I'm using mirrors and I've overwrited the central repo with my local repo.
> I've searched the whole Internet for ways to disable connections to http://repo1.maven.org
but this keeps happening... 
> You can consult my settings.xml in the attachments

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message