maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harald Lammers (JIRA)" <j...@codehaus.org>
Subject [jira] (MDEPLOY-141) Deploy fails for releases with repository deployment policy set to Disable Redeploy
Date Tue, 10 Sep 2013 21:35:52 GMT

    [ https://jira.codehaus.org/browse/MDEPLOY-141?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=332644#comment-332644
] 

Harald Lammers commented on MDEPLOY-141:
----------------------------------------

For us same problem. We use maven version 2.2.1.
Is it solved in maven 3.0.* or 3.1.*? 
                
> Deploy fails for releases with repository deployment policy set to Disable Redeploy
> -----------------------------------------------------------------------------------
>
>                 Key: MDEPLOY-141
>                 URL: https://jira.codehaus.org/browse/MDEPLOY-141
>             Project: Maven Deploy Plugin
>          Issue Type: Bug
>    Affects Versions: 2.7
>            Reporter: Manfred Schürhoff
>            Priority: Minor
>
> We recently switched from Archiva to Nexus. The deployment policy for the release repository
in Nexus is set to Disable Redeploy. However, this now causes problems that are described
in MDEPLOY-134 and MDEPLOY-137: when an artifact is uploaded, it first uploads the pom and
the artifact which works OK, but then it tries to upload the sources of the artifact (also
fine) and again the pom which fails with HTTP 400: 
> {noformat}Error deploying artifact: Failed to transfer file: http://nl-nexus/nexus/content/repositories/releases/<groupId>.<artifactId>.<version>.pom.
Return code is: 400{noformat}
> We were still using version 2.3 of the maven-deploy-plugin, but we switched to the latest
2.7 version hoping this would solve the issues described in MDEPLOY-134 and MDEPLOY-137, but
the problem still remains. We've also tried setting uniqueVersion to false for the releases
in distributionManagment, but that also doesn't help (and is something we'd rather not do).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message