maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Herve Boutemy (JIRA)" <j...@codehaus.org>
Subject [jira] (MPLUGIN-235) Doc example incorrectly states that plexus-utils is needed as a dependency
Date Wed, 06 Nov 2013 00:44:52 GMT

    [ https://jira.codehaus.org/browse/MPLUGIN-235?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=335239#comment-335239
] 

Herve Boutemy commented on MPLUGIN-235:
---------------------------------------

as you can see in MPLUGIN-229, the dependency was removed in plugin-tools 3.2, but the doc
wasn't updated
                
> Doc example incorrectly states that plexus-utils is needed as a dependency
> --------------------------------------------------------------------------
>
>                 Key: MPLUGIN-235
>                 URL: https://jira.codehaus.org/browse/MPLUGIN-235
>             Project: Maven Plugin Tools
>          Issue Type: Bug
>          Components: Plugin Plugin
>    Affects Versions: 3.2
>         Environment: n/a
>            Reporter: Anders Hammar
>            Assignee: Anders Hammar
>             Fix For: 3.3
>
>
> On the plugin site, in the "Using Plugin Tools Java5 Annotations" example, it states:
> {quote}
>     <!-- generated help mojo has a dependency to plexus-utils -->
>     <dependency>
>       <groupId>org.codehaus.plexus</groupId>
>       <artifactId>plexus-utils</artifactId>
>       <version>3.0.1</version>
>     </dependency>
> {quote}
> This is not correct and this dependency should be removed from the example.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message