maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Mehio (JIRA)" <j...@codehaus.org>
Subject [jira] (MNG-5501) Prerequisites don't work against Maven-3.1.0
Date Sat, 05 Jul 2014 09:22:11 GMT

    [ https://jira.codehaus.org/browse/MNG-5501?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=349190#comment-349190
] 

Alan Mehio edited comment on MNG-5501 at 7/5/14 4:21 AM:
---------------------------------------------------------

As per  maven pom specification from http://maven.apache.org/pom.html#Prerequisites 
  it states the following: 
"The POM may have certain prerequisites in order to execute correctly. For example, perhaps
there was a fix in Maven 2.0.3 that you need in order to deploy using sftp. Here is where
you give the prerequisites to building. If these are not met, Maven will fail the build before
even starting. The only element that exists as a prerequisite in POM 4.0 is the maven element,
which takes a minimum version number."

 It is still not working on maven 3.2.2  for invoking appengine-maven-plugin    which states
the below in its pom

<prerequisites>
        <maven>3.1.0</maven>
</prerequisites>

Regards,
Alan Mehio
London,UK




was (Author: alanmehio):
As per  maven pom specification from http://maven.apache.org/pom.html#Prerequisites 
  it states the following: 
"The POM may have certain prerequisites in order to execute correctly. For example, perhaps
there was a fix in Maven 2.0.3 that you need in order to deploy using sftp. Here is where
you give the prerequisites to building. If these are not met, Maven will fail the build before
even starting. The only element that exists as a prerequisite in POM 4.0 is the maven element,
which takes a minimum version number."

 It is still not working on maven 3.2.2  for invoking appengine-maven-plugin    which states
the below in its pom

<prerequisites>
        <maven>3.1.0</maven>
</prerequisites>





> Prerequisites don't work against Maven-3.1.0
> --------------------------------------------
>
>                 Key: MNG-5501
>                 URL: https://jira.codehaus.org/browse/MNG-5501
>             Project: Maven
>          Issue Type: Bug
>          Components: POM
>    Affects Versions: 3.0.4, 3.0.5, 3.1.0
>            Reporter: Michael Semb Wever
>
> adding 
> {code}<prerequisites><maven>3.1.0</maven></prerequisites>{code}
> does not stop the project from being built with mvn-3.0.4 or mvn-3.0.5
> Is Prerequisites suppose to work or not?
> Because there is no sign of it being deprecated throughout the documentation.
> (I don't want to use the enforcer plugin).



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message