maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Mehio (JIRA)" <j...@codehaus.org>
Subject [jira] (MNG-5660) prerequisites element in pom does not work on maven 3.2.2
Date Sun, 06 Jul 2014 15:53:10 GMT

    [ https://jira.codehaus.org/browse/MNG-5660?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=349206#comment-349206
] 

Alan Mehio edited comment on MNG-5660 at 7/6/14 10:52 AM:
----------------------------------------------------------

Jason,
 I have tested it using maven 3.2.2 and it works fine now 

The maven specification and the implementation matches. 
I will close this issue now.

Cheers
Alan Mehio


was (Author: alanmehio):
Jason,

Please close the issue. I have tested it using maven 3.2.2 and it works fine now 

The maven specification and the implementation matches. 
Please close this issue and mark it as invalid 

> prerequisites element in pom does not work on maven 3.2.2
> ---------------------------------------------------------
>
>                 Key: MNG-5660
>                 URL: https://jira.codehaus.org/browse/MNG-5660
>             Project: Maven
>          Issue Type: Bug
>          Components: Command Line, Errors
>    Affects Versions: 3.2.2
>         Environment: java 1.7
>            Reporter: Alan Mehio
>            Priority: Minor
>             Fix For: 3.2.x
>
>
> Failed to execute goal com.google.appengine:appengine-maven-plugin:1.9.6:devserver (default-cli)
on project guestbook: The plugin com.google
> .appengine:appengine-maven-plugin:1.9.6 requires Maven version 3.1.0 ->
> It should work on a min version of  3.1.0 and not exact same version as explained in
maven pom specification below:
> http://maven.apache.org/pom.html#Prerequisites
> "The POM may have certain prerequisites in order to execute correctly. For example, perhaps
there was a fix in Maven 2.0.3 that you need in order to deploy using sftp. Here is where
you give the prerequisites to building. If these are not met, Maven will fail the build before
even starting. The only element that exists as a prerequisite in POM 4.0 is the maven element,
which takes a minimum version number."
> look at the project   
> https://code.google.com/p/appengine-maven-plugin/
> and its usage  
> https://developers.google.com/appengine/docs/java/gettingstarted/ui_and_code
> and the command line which cause the issue
> "mvn appengine:devserver"
> error message :
>  Failed to execute goal com.google.appengine:appengine-maven-plugin:1.9.6:devserver (default-cli)
on project guestbook: The plugin com.google
> .appengine:appengine-maven-plugin:1.9.6 requires Maven version 3.1.0 -> [Help 1]
> the pom file from the  google app engine maven plugin
> ....
> <prerequisites>
>         <maven>3.1.0</maven>
> </prerequisites>
> .....



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message