maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tibor Digana (JIRA)" <j...@codehaus.org>
Subject [jira] (SUREFIRE-1068) forkNumber in systemPropertyVariables requires prefix
Date Fri, 02 Jan 2015 14:52:10 GMT

     [ https://jira.codehaus.org/browse/SUREFIRE-1068?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tibor Digana updated SUREFIRE-1068:
-----------------------------------

    Comment: was deleted

(was: Meanwhile this may work as well
{code}<surefire.forkNumber>\${surefire.forkNumber}</surefire.forkNumber>{code})

> forkNumber in systemPropertyVariables requires prefix
> -----------------------------------------------------
>
>                 Key: SUREFIRE-1068
>                 URL: https://jira.codehaus.org/browse/SUREFIRE-1068
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.16
>            Reporter: Eric Pederson
>            Assignee: Tibor Digana
>            Priority: Minor
>
> The {{$\{surefire.forkNumber\}}} placeholder cannot be used alone in a {{systemPropertyVariable}}.
 The workaround is to prefix the value.
> For example, this doesn't work (the {{surefire.forkNumber}} system property does not
exist when running the test).
> {code:xml}
>   <systemPropertyVariables>
>     <surefire.forkNumber>${surefire.forkNumber}</surefire.forkNumber>
>   </systemPropertyVariables>
> {code}
> But this does:
> {code:xml}
>   <systemPropertyVariables>
>     <surefire.forkNumber>0${surefire.forkNumber}</surefire.forkNumber>
>   </systemPropertyVariables>
> {code}
> (note the leading *0*)



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message