maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roland Wiesemann (JIRA)" <j...@codehaus.org>
Subject [jira] (MNG-5741) maven version range not working as expected
Date Sun, 04 Jan 2015 21:31:10 GMT

     [ https://jira.codehaus.org/browse/MNG-5741?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Roland Wiesemann closed MNG-5741.
---------------------------------

    Resolution: Not A Bug

> maven version range not working as expected
> -------------------------------------------
>
>                 Key: MNG-5741
>                 URL: https://jira.codehaus.org/browse/MNG-5741
>             Project: Maven
>          Issue Type: Bug
>          Components: Dependencies
>    Affects Versions: 3.2.5
>         Environment: Windows / Java 7
>            Reporter: Roland Wiesemann
>         Attachments: example.tgz
>
>
> The example is attached to this issue.
> - First, install the *test:artifact 1.0.0* into the local repository
> - Second, install the *test:artifact 1.1.0-SNAPSHOT* to the local repository
> - Thirdly, by the query of the list of the dependence within test:use-artifact-range
appears the artefact *test:artefact:1. 1. 0-SNAPSHOT*.
> However, for the version range [1. 0. 0,1. 1) I have expected the *artefact test:artefact:1.
0. 0*.  



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message