maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tibor Digana (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (SUREFIRE-1138) Enabling reuseForks runs all tests in series on just one fork
Date Sat, 04 Jul 2015 09:07:04 GMT

     [ https://issues.apache.org/jira/browse/SUREFIRE-1138?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tibor Digana closed SUREFIRE-1138.
----------------------------------
    Resolution: Fixed

commit	d4aa9b7ac3aa36a229170ed8fb2993df5440e561

> Enabling reuseForks runs all tests in series on just one fork
> -------------------------------------------------------------
>
>                 Key: SUREFIRE-1138
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1138
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.18, 2.18.1
>         Environment: Apache Maven 3.0.4 (r1232337; 2012-01-17 19:44:56+1100)
> Java version: 1.7.0_17, vendor: Oracle Corporation
> Ubuntu 12.04 LTS
>            Reporter: Matthew Provis
>            Assignee: Tibor Digana
>             Fix For: 2.19
>
>         Attachments: test.zip
>
>
> When using Surefire >= 2.18, I've encountered a problem when setting {{forkCount >
1}} and {{reuseForks = true}}.
> Expected behaviour:
> Tests should run simultaneously, each on a separate fork.
> Actual behaviour:
> All tests run on just one fork, sequentially.
> Setting {{reuseForks = false}} gives the expected behaviour. 
> Reverting to Surefire 2.17 also gives the expected behaviour.
> I've attached a project that demonstrates the issue. Here I've created two tests, each
of which prints the fork number and sleeps for 5 seconds. The total run time is 10 seconds
with Surefire 2.18 and 2.18.1, but 5 seconds with version 2.17.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message