maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hervé Boutemy (JIRA) <j...@apache.org>
Subject [jira] [Updated] (MNG-5881) Resource not put into jar
Date Sat, 05 Sep 2015 11:42:46 GMT

     [ https://issues.apache.org/jira/browse/MNG-5881?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hervé Boutemy updated MNG-5881:
-------------------------------
    Description: 
I have a resource that I am copying to the target/classes directory using the maven-dependency-plugin
version 2.10.  The <outputDirectory> is specified as:
{noformat}     ${project.build.outputDirectory}/OSGI-INF/blueprint{noformat}
I am doing so in the "validate" phase.

After doing a "clean install", the file is in the {{/target/classes/OSGI-INF/blueprint}} directory
alongside
2 other files that were in the {{src/main/resources/OSGI-INF/blueprint}} directory.
However, the file does not appear in the output jar file.  From posts on the
web it appears that all files in the classes directory should be copied into
the jar.

I tried using the dependency copy plugin to copy it first to another folder and then using
the maven resources plugin to copy it to the $\{project.build.outputDirectory}/OSGI-INF/blueprint
directory.
That did not work either.
I am using maven version 3.2.3.

It is an .xml file just like the other files from the {{src/main/resources}}. 

  was:
I have a resource that I am copying to the target/classes directory using the maven-dependency-plugin
version 2.10.  The <outputDirectory> is specified as:
{noformat}     ${project.build.outputDirectory}/OSGI-INF/blueprint{noformat}
I am doing so in the "validate" phase.

After doing a "clean install", the file is in the {{/target/classes/OSGI-INF/blueprint}} directory
alongside
2 other files that were in the {{src/main/resources/OSGI-INF/blueprint}} directory.
However, the file does not appear in the output jar file.  From posts on the
web it appears that all files in the classes directory should be copied into
the jar.

I tried using the dependency copy plugin to copy it first to another folder and then using
the maven resources plugin to copy it to the $\{project.build.outputDirectory}/OSGI-INF/blueprint
directory.
That did not work either.
I am using maven version 3.2.3.

It is an .xml file just like the other files from the{{ src/main/resources}}. 


> Resource not put into jar
> -------------------------
>
>                 Key: MNG-5881
>                 URL: https://issues.apache.org/jira/browse/MNG-5881
>             Project: Maven
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 3.2.3
>         Environment: windows 7
>            Reporter: Douglas Jackson
>         Attachments: maven-test.zip
>
>
> I have a resource that I am copying to the target/classes directory using the maven-dependency-plugin
> version 2.10.  The <outputDirectory> is specified as:
> {noformat}     ${project.build.outputDirectory}/OSGI-INF/blueprint{noformat}
> I am doing so in the "validate" phase.
> After doing a "clean install", the file is in the {{/target/classes/OSGI-INF/blueprint}}
directory alongside
> 2 other files that were in the {{src/main/resources/OSGI-INF/blueprint}} directory.
> However, the file does not appear in the output jar file.  From posts on the
> web it appears that all files in the classes directory should be copied into
> the jar.
> I tried using the dependency copy plugin to copy it first to another folder and then
using the maven resources plugin to copy it to the $\{project.build.outputDirectory}/OSGI-INF/blueprint
directory.
> That did not work either.
> I am using maven version 3.2.3.
> It is an .xml file just like the other files from the {{src/main/resources}}. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message