maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael K (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MENFORCER-156) Upgrading maven-enforcer-plugin from 1.2 to 1.3 breaks maven-assembly-plugin
Date Tue, 16 Feb 2016 19:08:18 GMT

    [ https://issues.apache.org/jira/browse/MENFORCER-156?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15149113#comment-15149113
] 

Michael K commented on MENFORCER-156:
-------------------------------------

I've also seen this bug reoccuring in our project after switching from maven-enforcer-plugin
1.4 to 1.4.1.

> Original test is good enough to reproduce it.

Well, yes and no.
Use the attached pom.xml and extjars.xml and
* set the maven-enforcer-plugin version to 1.3.1 or 1.4: Success.
* set the m-e-p version to 1.4.1: It fails with the same error message as reported for 1.3.
* set the m-e-p version to 1.4.1 and update the maven-assembly-plugin version to 2.6: Success.
So, an updated version (with the current m-a-p version) of the provided POM is not sufficient
enough to reproduce the problem.

Unfortunately, in our project, that hasn't helped. Still fails with the same error message
with m-e-p 1.4.1 and m-a-p 2.6.

[~hakamairi]: Have you tried to use m-a-p 2.6? Does the problem persist? Can you isolate it?


> Upgrading maven-enforcer-plugin from 1.2 to 1.3 breaks maven-assembly-plugin
> ----------------------------------------------------------------------------
>
>                 Key: MENFORCER-156
>                 URL: https://issues.apache.org/jira/browse/MENFORCER-156
>             Project: Maven Enforcer Plugin
>          Issue Type: Bug
>    Affects Versions: 1.3
>         Environment: Ubuntu 12.04 fully patched / Maven 3.0.5 / Oracle Java 1.7.0_25
>            Reporter: Wolf Geldmacher
>            Assignee: Robert Scholte
>            Priority: Blocker
>             Fix For: 1.3.1
>
>         Attachments: extjars.xml, pom.xml
>
>
> After upgrading m-e-p from 1.2 to 1.3 the maven-assembly-plugin generates the following
error:
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.4:single
(assemble) on project extjars: Execution assemble of goal org.apache.maven.plugins:maven-assembly-plugin:2.4:single
failed. NullPointerException -> [Help 1] 
> Downgrading to m-e-p 1.2 makes the assembly work again.
> Sample pom & assembly that expose the error attached.
> When called via:
>     mvn -Dplugins.maven-enforcer-plugin.version=1.2
> a zip file is generated as expected, when called via
>     mvn -Dplugins.maven-enforcer-plugin.version=1.3
> (or without argument) you will get the NPE.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message