maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MNG-4792) Preemptive authentication doesn't work
Date Sun, 11 Dec 2016 19:23:58 GMT

     [ https://issues.apache.org/jira/browse/MNG-4792?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte updated MNG-4792:
--------------------------------
    Description: 
It seems preemptive authentication in Maven using httpclient wagon provider doesn't work.
With configuration taken form [1] Maven knock to repository (tested with Artifactory 2.2.5)
as anonymous user.
{code:xml}
<server>
 <id>repo-id</id>
 <username>user</username>
 <password>pass</password>
 <configuration>
  <wagonProvider>httpclient</wagonProvider>
  <httpConfiguration>
   <put>
    <params>
     <param>
      <name>http.authentication.preemptive</name>
      <value>%b,true</value>
     </param>
    </params>
   </put>
  </httpConfiguration>
 </configuration>
</server>
{code}
Confirmed by independent party also with Maven 2.2.1. I can sniff http traffic if needed.

[1] - http://maven.apache.org/guides/mini/guide-http-settings.html

  was:
It seems preemptive authentication in Maven using httpclient wagon provider doesn't work.
With configuration taken form [1] Maven knock to repository (tested with Artifactory 2.2.5)
as anonymous user.

<server>
 <id>repo-id</id>
 <username>user</username>
 <password>pass</password>
 <configuration>
  <wagonProvider>httpclient</wagonProvider>
  <httpConfiguration>
   <put>
    <params>
     <param>
      <name>http.authentication.preemptive</name>
      <value>%b,true</value>
     </param>
    </params>
   </put>
  </httpConfiguration>
 </configuration>
</server>

Confirmed by independent party also with Maven 2.2.1. I can sniff http traffic if needed.

[1] - http://maven.apache.org/guides/mini/guide-http-settings.html


> Preemptive authentication doesn't work
> --------------------------------------
>
>                 Key: MNG-4792
>                 URL: https://issues.apache.org/jira/browse/MNG-4792
>             Project: Maven
>          Issue Type: Bug
>          Components: Artifacts and Repositories
>    Affects Versions: 2.2.1
>         Environment: Sun Java 1.6.0_21, Windows 7
>            Reporter: Marcin Zajaczkowski
>            Assignee: Olivier Lamy (*$^¨%`£)
>             Fix For: 3.0.4
>
>
> It seems preemptive authentication in Maven using httpclient wagon provider doesn't work.
With configuration taken form [1] Maven knock to repository (tested with Artifactory 2.2.5)
as anonymous user.
> {code:xml}
> <server>
>  <id>repo-id</id>
>  <username>user</username>
>  <password>pass</password>
>  <configuration>
>   <wagonProvider>httpclient</wagonProvider>
>   <httpConfiguration>
>    <put>
>     <params>
>      <param>
>       <name>http.authentication.preemptive</name>
>       <value>%b,true</value>
>      </param>
>     </params>
>    </put>
>   </httpConfiguration>
>  </configuration>
> </server>
> {code}
> Confirmed by independent party also with Maven 2.2.1. I can sniff http traffic if needed.
> [1] - http://maven.apache.org/guides/mini/guide-http-settings.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message