maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <>
Subject [jira] [Moved] (MRELEASE-972) DOES NOT show SSL debug output
Date Thu, 08 Dec 2016 22:20:58 GMT


Robert Scholte moved MNG-6134 to MRELEASE-972:

    Affects Version/s:     (was: 3.3.9)
                  Key: MRELEASE-972  (was: MNG-6134)
              Project: Maven Release Plugin  (was: Maven)

> DOES NOT show SSL debug output
> ---------------------------------------------------------------
>                 Key: MRELEASE-972
>                 URL:
>             Project: Maven Release Plugin
>          Issue Type: Bug
>         Environment: Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T09:41:47-07:00)
> Java version: 1.8.0_45, vendor: Oracle Corporation
> Java home: /Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Home/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "mac os x", version: "10.11.6", arch: "x86_64", family: "mac"
>            Reporter: Dmitriy Tserekhman
> Hi,
> I'm trying to use "mvn release:prepare" where <connection/> and <developerConnection/>
of the <scm/> attribute in my pom.xml specify "https" url to the nexus server which
has a self-signed certificate.
> I did imported this self-signed certificate into "cacerts" of the JAVA_HOME used by my
Maven, but I'm still getting this error:
> fatal: unable to access 'https:/<my nexus server url>': SSL certificate problem:
Invalid certificate chain
> I tried to enable SSL debug by setting MAVEN_OPTS to understand the problem better, but
am still not getting any more debug messaging:
> The "-X" and "-e" maven parameters only show the stacktrace from the "release" plug-in
where the error is being thrown, but does not reflect any SSL debug information.
> Provider message:
> The git-push command failed.
> Command output:
> fatal: unable to access 'https://<my nexus server url>': SSL certificate problem:
Invalid certificate chain
> 	at org.apache.maven.plugins.release.PrepareReleaseMojo.prepareRelease(
> 	at org.apache.maven.plugins.release.PrepareReleaseMojo.execute(
> 	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(
> 	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> 	... 20 more
> On the other hand, when I use same JAVA_HOME by other Java programs that access same
nexus server URL, I do not get this SSL error.

This message was sent by Atlassian JIRA

View raw message