maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (WAGON-469) wagon-http does not enable Expect-Continue by default
Date Sat, 10 Dec 2016 00:29:58 GMT

     [ https://issues.apache.org/jira/browse/WAGON-469?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Osipov closed WAGON-469.
--------------------------------
    Resolution: Fixed

Fixed with [5d600267c4e8f1a27b32bed91a557e696bd66fc3|https://git-wip-us.apache.org/repos/asf?p=maven-wagon.git;a=commit;h=5d600267c4e8f1a27b32bed91a557e696bd66fc3].

> wagon-http does not enable Expect-Continue by default
> -----------------------------------------------------
>
>                 Key: WAGON-469
>                 URL: https://issues.apache.org/jira/browse/WAGON-469
>             Project: Maven Wagon
>          Issue Type: Bug
>          Components: wagon-http
>    Affects Versions: 2.10
>            Reporter: Stuart McCulloch
>            Assignee: Michael Osipov
>             Fix For: 2.11
>
>
> According to http://maven.apache.org/guides/mini/guide-http-settings.html#The_Basics
PUT requests made with the HTTP wagon will enable Expect-Continue support by default.
> However testing shows that when no {{<httpConfiguration>}} is provided in settings.xml
Expect-Continue support is not enabled by wagon-http for PUT requests.
> Similarly, when an empty {{<httpConfiguration>}} section is provided in settings.xml,
Expect-Continue support is not enabled by wagon-http for PUT requests.
> Only when a {{<httpConfiguration>}} section like:
> {code:xml}
> <put>
>   <params>
>     <property>
>       <name>http.protocol.expect-continue</name>
>       <value>%b,true</value>
>     </property>
>   </params>
> </put>
> {code}
> is provided in settings.xml is Expect-Continue support enabled.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message