maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abel Salgado Romero (JIRA)" <>
Subject [jira] [Commented] (MINVOKER-226) run goal failing on Windows + OracleJDK 8-144
Date Tue, 26 Sep 2017 19:27:02 GMT


Abel Salgado Romero commented on MINVOKER-226:

Found a workaround...
Thing is I am running this from a normal windows shell (cmd.exe) but setting the PATH to the
maven I have installed with sdkman.
I just moved the mvn installation to another directory and it works, the same exact files
and it works.
I tested It many times moving it back and forth and this is the cause. I also tried to reproduce
it creating other long paths and with some directories whose name start with dot, but no luck.

For instance, this is the path that fails {{I:\babun\.babun\cygwin\home\abelsr\.sdkman\candidates\maven}},
but this works {{I:\JavaStuff\.hidden\dir1\dir2\.hidden2\apache-maven-3.5.0}}.

So, I guess we can close the issue. I am not 100% comforted, but this is a really weird combination.

Note that I've been using this maven settup for more than 3 years and nothing ever happened
and also, I don't recall any issues with previous version of Java, btw, tested with Java9
and also fails.

> run goal failing on Windows + OracleJDK 8-144
> ---------------------------------------------
>                 Key: MINVOKER-226
>                 URL:
>             Project: Maven Invoker Plugin
>          Issue Type: Bug
>         Environment: Windows 7 and Windows 8.1 (2 different machines)
> Oracle JDK 8-144
> Maven 3.5.0
> maven-invoker-plugin: from 2.0.0 to 3.0.1
>            Reporter: Abel Salgado Romero
>            Priority: Minor
>         Attachments: logs.txt
> maven-invoker-plugin (version 2.0.0) run goal started failing on Windows 8.1 and Windows
7 with OracleJDK 8.144. It worked fine previously.
> Runs OK on MacOS (JDK 8-133 and 8-144), and Ubuntu TraviCI and Windows AppVeyor.
> Though the issue started with invoker 2.0.0, I am fine to focus on 3.0.1 since it's the
current version. Also 2.0.0 and 3.0.0 show a different error.
> With 3.0.1 everything seems to run fine but the validation scripts fail because they
cannot find the generated files of the plugin being tested (see this branch
> That's true, the target directory does not hold the generated files but running with
-X shows that the goals are apparently executed as seen by the line
> {{[DEBUG] Executing: cmd.exe /X /C "I:\babun\.babun\cygwin\home\abelsr\.sdkman\candidates\maven\3.5.0\bin\mvn.cmd
-B -X -D maven.repo.local=C:\Users\abelsr\.m2\repository -s C:\Users\abelsr\AppData\Local\Temp\invoker-settings4165519454880719356.xml
clean asciidoctor:process-asciidoc"}}
> Running the same command without the custom settings file in the it-tests directory works
fine and generates the files.
> NOTE: even if you see in the paths of the attached log that files are in a Babun home,
I run the command {{mvn clean verify -Prun-its -X}} from a standard cmd shell.
> Could it be, that the plugin runs the tests on another directory?

This message was sent by Atlassian JIRA

View raw message