maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Wilkins (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MNG-6290) java.security.InvalidAlgorithmParameterException with java 9
Date Sat, 30 Sep 2017 21:50:00 GMT
Greg Wilkins created MNG-6290:
---------------------------------

             Summary: java.security.InvalidAlgorithmParameterException with java 9
                 Key: MNG-6290
                 URL: https://issues.apache.org/jira/browse/MNG-6290
             Project: Maven
          Issue Type: Bug
          Components: Dependencies
    Affects Versions: 3.5.0
         Environment: Ubuntu
            Reporter: Greg Wilkins


Using 
{{
openjdk version "9"
OpenJDK Runtime Environment (build 9+181)
OpenJDK 64-Bit Server VM (build 9+181, mixed mode)
}}

with some missing dependencies results in 
{{
[ERROR] Plugin org.apache.maven.plugins:maven-failsafe-plugin:2.20.1 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-failsafe-plugin:jar:2.20.1:
Could not transfer artifact org.apache.maven.plugins:maven-failsafe-plugin:pom:2.20.1 from/to
central (https://repo.maven.apache.org/maven2): java.lang.RuntimeException: Unexpected error:
java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
-> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
}}

switching back to java 8 allows the dependencies to be resolved and then mvn appears to work
fine in java 9.

removing the dependency makes the failure re-occur.  In my case the missing dependency is
{{ org/apache/maven/plugins/maven-failsafe-plugin/2.20.1/maven-failsafe-plugin-2.20.1.jar}}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message