maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tibor Digana (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SUREFIRE-1388) NullPointerException caused by DefaultReporterFactory.printTestFailures(DefaultReporterFactory.java:403)
Date Tue, 03 Oct 2017 14:36:00 GMT

    [ https://issues.apache.org/jira/browse/SUREFIRE-1388?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16189775#comment-16189775
] 

Tibor Digana commented on SUREFIRE-1388:
----------------------------------------

[~ruudp]
[~ruud.paulissen]
I will close this because I could not find a problem in Surefire code; otherwise same error
would appear even without JUnit Platform.
You should ask the JUnit team how they implement {{org.apache.maven.surefire.report.RunListener#testFailed(
ReportEntry )}} and {{org.apache.maven.surefire.report.RunListener#testError( ReportEntry
)}}.
Most probably the problem NPE has happened is that their {{ReportEntry#getStackTraceWriter()}}
returns NULL.




> NullPointerException caused by DefaultReporterFactory.printTestFailures(DefaultReporterFactory.java:403)
> --------------------------------------------------------------------------------------------------------
>
>                 Key: SUREFIRE-1388
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1388
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.19, 2.20
>         Environment: Kotlin Spek
>            Reporter: Ruud Paulissen
>            Assignee: Tibor Digana
>              Labels: DefaultReporterFactory, NullPointerException
>             Fix For: Backlog
>
>         Attachments: pom kopie.xml, Schermafbeelding 2017-07-11 om 09.59.23.png
>
>
> I'm trying to run Kotlin Spek tests (based on JUnit) from Maven. I've followed the guide
on their website, and can run the tests locally perfectly fine.
> When I run the Maven "test" task however, some tests are annotated with "FAILURE" in
the output, with a plain "null" value appearing in the console. Upon running "mvn test -e",
I get the attached stack trace.
> I have attached my maven pom.xml file as well.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message