maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jiří Pejchal (JIRA) <j...@apache.org>
Subject [jira] [Commented] (MPMD-247) Upgrade to PMD 6.0.0
Date Fri, 15 Dec 2017 22:28:00 GMT

    [ https://issues.apache.org/jira/browse/MPMD-247?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16293365#comment-16293365
] 

Jiří Pejchal commented on MPMD-247:
-----------------------------------

pmd 6.0 is released:
{code}Execution pmd of goal org.apache.maven.plugins:maven-pmd-plugin:3.8:pmd failed: A required
class was missing while executing org.apache.maven.plugins:maven-pmd-plugin:3.8:pmd: net/sourceforge/pmd/PropertyDescriptor{code}

> Upgrade to PMD 6.0.0
> --------------------
>
>                 Key: MPMD-247
>                 URL: https://issues.apache.org/jira/browse/MPMD-247
>             Project: Maven PMD Plugin
>          Issue Type: Improvement
>          Components: CPD, PMD
>            Reporter: Andreas Dangel
>            Assignee: Andreas Dangel
>             Fix For: 3.9.0
>
>
> Once PMD 6.0.0 is released, we should upgrade to it.
> Changes:
> * Small API change in RuleSetFactory (uses now a ResourceLoader instead of a ClassLoader
directly)
> * RuleSets have been reorganized into categories
> ** we need to adjust the default values for rulesets
> ** either PMD provides a default getting started ruleset or the maven plugin should provide
it



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message