maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] FauxFaux opened a new pull request #1: Switch aether imports to maven-resolver
Date Thu, 01 Jan 1970 00:00:00 GMT
FauxFaux opened a new pull request #1: Switch aether imports to maven-resolver
URL: https://github.com/apache/maven-common-artifact-filters/pull/1
 
 
   Stop using the old `aether` and `eclipse-aether` libraries, who's code is now part of `maven-resolver`,
under the `org.eclipse` package. The old libraries are very abandoned, to the point that their
websites have gone missing. They depend on some scarily broken libraries, which is a problem
for distros like Debian.
   
   Tests green. Only non-find-and-replace changes is to add some properties:
    * `<javaVersion>7` as `maven-resolver` uses 7 and otherwise enforcer gets angry,
and
    * `<maven.version>3.5.2`, as pre-3.5 maven used aether for other reasons, so it
still ends up polluting the tree.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message