maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MCOMPILER-338) Build Issue based on MCOMPILER-192 IT
Date Sat, 14 Apr 2018 09:22:00 GMT

     [ https://issues.apache.org/jira/browse/MCOMPILER-338?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karl Heinz Marbaise updated MCOMPILER-338:
------------------------------------------
    Description: 
Currently the master is blocked by not working IT {{MCOMPILER-192}} which fails.

The issue is related to the differences of platform/os which results in failing the {{verify.groovy}}
which was originally implemented for one platform but based on our intention to build on different
platforms and JDK's which is really needed this fails.

The things which needed to be done:
* Upgrade surefire.version to 2.21.0 (to work in JDK 10)
*  MCOMPILER-197/invoker.properties
** We need to limit the run to 1.6, 1.7, 1.8 cause openjpa has no version which woks for JDK
9 / 10
* src/test/java/org/apache/maven/plugin/compiler/CompilerMojoTestCase.java
** Need to change the source/target to have 6 instead of 5 cause JDK9/JDK10 do not support
source/target 5 anymore.
** I think we should change this setup and find a better way.
* groovy-project-with-new-plexus-compiler
** Needed run only for 1.6, 1.7 and 1.8
* MCOMPILER-192/verify.groovy
** Had to limit the comparison to particular areas of the output

  was:
Currently the master is blocked by not working IT {{MCOMPILER-192}} which fails.

The issue is related to the differences of platform/os which results in failing the {{verify.groovy}}
which was originally implemented for one platform but based on our intention to build on different
platforms and JDK's which is really needed this fails.

The things which needed to be done:
* Upgrade surefire.version to 2.21.0 (to work in JDK 10)
*  MCOMPILER-197/invoker.properties
** We need to limit the run to 1.6, 1.7, 1.8 cause openjpa has no version which woks for JDK
9 / 10
* src/test/java/org/apache/maven/plugin/compiler/CompilerMojoTestCase.java
** Need to change the source/target to have 6 instead of 5 cause JDK9/JDK10 do not support
source/target 5 anymore.
** I think we should change this setup and find a better way.
* MCOMPILER-192/verify.groovy
** Had to limit the comparison to particular areas of the output


> Build Issue based on MCOMPILER-192 IT
> -------------------------------------
>
>                 Key: MCOMPILER-338
>                 URL: https://issues.apache.org/jira/browse/MCOMPILER-338
>             Project: Maven Compiler Plugin
>          Issue Type: Bug
>    Affects Versions: 3.7.1
>            Reporter: Karl Heinz Marbaise
>            Assignee: Karl Heinz Marbaise
>            Priority: Blocker
>             Fix For: 3.7.1
>
>
> Currently the master is blocked by not working IT {{MCOMPILER-192}} which fails.
> The issue is related to the differences of platform/os which results in failing the {{verify.groovy}}
which was originally implemented for one platform but based on our intention to build on different
platforms and JDK's which is really needed this fails.
> The things which needed to be done:
> * Upgrade surefire.version to 2.21.0 (to work in JDK 10)
> *  MCOMPILER-197/invoker.properties
> ** We need to limit the run to 1.6, 1.7, 1.8 cause openjpa has no version which woks
for JDK 9 / 10
> * src/test/java/org/apache/maven/plugin/compiler/CompilerMojoTestCase.java
> ** Need to change the source/target to have 6 instead of 5 cause JDK9/JDK10 do not support
source/target 5 anymore.
> ** I think we should change this setup and find a better way.
> * groovy-project-with-new-plexus-compiler
> ** Needed run only for 1.6, 1.7 and 1.8
> * MCOMPILER-192/verify.groovy
> ** Had to limit the comparison to particular areas of the output



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message