maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MGPG-68) maven-gpg-plugin doesn't actually work with gpgv2
Date Fri, 02 Nov 2018 23:06:00 GMT

    [ https://issues.apache.org/jira/browse/MGPG-68?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16673798#comment-16673798
] 

Allen Wittenauer commented on MGPG-68:
--------------------------------------

I clearly wasn't awake.  The command is 'gpg2' not 'gpgv2' and it works just fine.  I can't
close this, otherwise I would. :(

> maven-gpg-plugin doesn't actually work with gpgv2
> -------------------------------------------------
>
>                 Key: MGPG-68
>                 URL: https://issues.apache.org/jira/browse/MGPG-68
>             Project: Maven GPG Plugin
>          Issue Type: Bug
>    Affects Versions: 1.6
>            Reporter: Allen Wittenauer
>            Priority: Major
>
> The documentation states:
> {code}
> Passes --use-agent or --no-use-agent to gpg. If using an agent, the passphrase is optional
as the agent will provide it. For gpg2, specify true as --no-use-agent was removed in gpg2
and doesn't ask for a passphrase anymore.
> Default value is: true.
> User property is: gpg.useagent.
> {code}
> ... except setting gpg.useagent to true results in '--use-agent' being passed which also
isn't supported (at least by gpg v2.1.11).  There really needs to be a 3rd option here.
> Sidenote: the top level Apache pom is trying to set '--digest-algo=SHA512' which also
isn't supported.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message