maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MNG-6516) Build maven-mojo using Java9 fails
Date Wed, 21 Nov 2018 19:17:00 GMT

    [ https://issues.apache.org/jira/browse/MNG-6516?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16695147#comment-16695147
] 

Robert Scholte commented on MNG-6516:
-------------------------------------

Please read [http://markmail.org/message/alvxfry2whuf6pk5] for more details.

> Build maven-mojo using Java9 fails
> ----------------------------------
>
>                 Key: MNG-6516
>                 URL: https://issues.apache.org/jira/browse/MNG-6516
>             Project: Maven
>          Issue Type: Bug
>          Components: Plugin API
>         Environment: java 9
>            Reporter: Matthias Fuchs
>            Priority: Major
>              Labels: java9, modules
>
> I'm upgrading my Java8 framework to Java9, but I have major problems upgrading my mojos
(https://github.com/spot-next/spot-framework/tree/develop/spot-maven-plugin).
> The problem is that my dependecies maven-artifact a maven-core contain the same classes.
This causes the java9 compiler to fail. It also seems that those libraries haven't been upgraded
to use module-info.java or at least automatic module name in META-INF.
> Expected solution:
> restructure the libraries to conform to the java module system.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message