maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabriel Belingueres (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MENFORCER-277) Upgrade maven-dependency-tree to 3.x
Date Wed, 26 Dec 2018 19:49:00 GMT

    [ https://issues.apache.org/jira/browse/MENFORCER-277?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16729161#comment-16729161
] 

Gabriel Belingueres commented on MENFORCER-277:
-----------------------------------------------

Hi [~rfscholte]: I've been working in adding the remaining functionality in m-dependency-tree.

I've tested the m-enforcer-plugin using your patch as base and it seems to work in most relevant
Maven versions (see MSHARED-788).

I could push a PR on this issue if required.

Regards,

Gabriel

> Upgrade maven-dependency-tree to 3.x
> ------------------------------------
>
>                 Key: MENFORCER-277
>                 URL: https://issues.apache.org/jira/browse/MENFORCER-277
>             Project: Maven Enforcer Plugin
>          Issue Type: Improvement
>    Affects Versions: 1.4.1
>            Reporter: Robert Scholte
>            Priority: Major
>         Attachments: MENFORCER-277.patch
>
>
> As part of MENFORCER-264 maven-dependency-tree should be upgraded. This would imply switching
from the M2 {{DependencyTreeBuilder}} to M2/M3 {{DependencyGraphBuilder}}.
> However, {{DependencyGraphBuilder}} uses {{ProjectDependenciesResolver}}, which provides
the *resolved* graph instead of a raw tree.
> This is a requirement for both {{DependencyConvergence}} and {{RequireUpperBoundDeps}}.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message