maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "lefebvre (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MRESOLVER-66) settings task does not load repositories defined into settings.xml
Date Fri, 15 Feb 2019 10:41:00 GMT
lefebvre created MRESOLVER-66:
---------------------------------

             Summary: settings task does not load repositories defined into settings.xml
                 Key: MRESOLVER-66
                 URL: https://issues.apache.org/jira/browse/MRESOLVER-66
             Project: Maven Resolver
          Issue Type: Bug
          Components: ant tasks
    Affects Versions: 1.3.1
            Reporter: lefebvre


my-settings.xml :

 <?xml version="1.0"?>
<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
 xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
 http://maven.apache.org/xsd/settings-1.0.0.xsd">

<interactiveMode>false</interactiveMode>

<servers>
 <server>
 <id>my-repo</id>
 <configuration>
 <httpHeaders>
 <property>
 <name>Private-Token</name>
 <value>XXX</value>
 </property>
 </httpHeaders>
 </configuration>
 </server>
 </servers>

<profiles>
 <profile>
 <id>enable-repos</id>
 <repositories>
 <repository>
 <id>central</id>
 <name>central</name>
 <url>http://repo1.maven.org/maven2</url>
 </repository>
 <repository>
 <id>my-repo</id>
 <name>my repository</name>
 <url>XXX</url>
 </repository>
 </repositories>
 </profile>
 </profiles>

<activeProfiles>
 <activeProfile>enable-repos</activeProfile>
 </activeProfiles>
</settings>

 

{{<settings file="my-settings.xml" globalfile="my-settings.xml"/>}}

 

{{The resolver task does not try to resolve artifacts using "my-repo" }}{{}}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message