maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mickael Istria (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MNG-6642) Tycho-based modules do not build with 3.6.1 (works with 3.6.0)
Date Thu, 02 May 2019 20:00:00 GMT

    [ https://issues.apache.org/jira/browse/MNG-6642?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16831917#comment-16831917
] 

Mickael Istria commented on MNG-6642:
-------------------------------------

Is there something that should be done in Tycho to improve that and let Maven remove the maven-compat
dep without causing any issue?
Or is it affecting all forms of non m2 repo layouts?

> Tycho-based modules do not build with 3.6.1 (works with 3.6.0)
> --------------------------------------------------------------
>
>                 Key: MNG-6642
>                 URL: https://issues.apache.org/jira/browse/MNG-6642
>             Project: Maven
>          Issue Type: Bug
>    Affects Versions: 3.6.1
>            Reporter: Francesco Chicchiriccò
>            Assignee: Sylwester Lachiewicz
>            Priority: Major
>             Fix For: 3.6.2
>
>
> Build does not work with Maven 3.6.1 (works fine with Maven 3.6.0).
> How to reproduce:
> # git clone https://github.com/apache/syncope.git
> # git checkout 2_1_X
> # $M2_HOME/bin/mvn clean
> When {{M2_HOME}} points to 3.6.0, build goes fine.
> When {{M2_HOME}} points to 3.6.1, the following output is reported:
> {code}
> [INFO] Scanning for projects...
> [INFO] Computing target platform for MavenProject: org.apache.syncope.ide.eclipse:org.apache.syncope.ide.eclipse.plugin:2.1.4-SNAPSHOT
@ /home/ilgrosso/work/syncope/syncope/ide/eclipse/bundles/org.apache.syncope.ide.eclipse.plugin/pom.xml
> [INFO] Resolving dependencies of MavenProject: org.apache.syncope.ide.eclipse:org.apache.syncope.ide.eclipse.plugin:2.1.4-SNAPSHOT
@ /home/ilgrosso/work/syncope/syncope/ide/eclipse/bundles/org.apache.syncope.ide.eclipse.plugin/pom.xml
> [INFO] {osgi.os=linux, osgi.ws=gtk, org.eclipse.update.install.features=true, osgi.arch=x86}
> [ERROR] Cannot resolve project dependencies:
> [ERROR]   Software being installed: org.apache.syncope.ide.eclipse.plugin 2.1.4.qualifier
> [ERROR]   Missing requirement: org.apache.syncope.ide.eclipse.plugin 2.1.4.qualifier
requires 'osgi.bundle; org.eclipse.ui 0.0.0' but it could not be found
> [ERROR] 
> [ERROR] See http://wiki.eclipse.org/Tycho/Dependency_Resolution_Troubleshooting for help.
> [ERROR] Cannot resolve dependencies of MavenProject: org.apache.syncope.ide.eclipse:org.apache.syncope.ide.eclipse.plugin:2.1.4-SNAPSHOT
@ /home/ilgrosso/work/syncope/syncope/ide/eclipse/bundles/org.apache.syncope.ide.eclipse.plugin/pom.xml:
See log for details -> [Help 1]
> [ERROR] 
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR] 
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MavenExecutionException
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message