maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph Keller (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MNG-6652) Offline mode not working
Date Fri, 03 May 2019 02:48:00 GMT

    [ https://issues.apache.org/jira/browse/MNG-6652?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16832165#comment-16832165
] 

Joseph Keller commented on MNG-6652:
------------------------------------

I think I found the problem.   I was using a different settings file when building in offline
mode.  The repos defined in there are not identical.   What's weird is that we have been
doing it this way for years and never had a problem before.

This Jira can be closed

 

> Offline mode not working
> ------------------------
>
>                 Key: MNG-6652
>                 URL: https://issues.apache.org/jira/browse/MNG-6652
>             Project: Maven
>          Issue Type: Bug
>          Components: Dependencies
>    Affects Versions: 3.3.3, 3.6.1
>            Reporter: Joseph Keller
>            Priority: Major
>         Attachments: offline.log, repo.zip
>
>
> We are having problems building in "offline" mode.   I can build a POM fine normally
(not using offline mode) and this should populate the local cache with all the dependencies,
correct?   But if I IMMEDIATLY run the same build with "-o" it fails because it can't find
one of the dependencies.  Shouldn't this work?
>  mvn  clean package          - works and populates local cache
>  mvn  -o clean package     - fails with following error
> Failed to execute goal on project nifi-hadoop-utils: Could not resolve dependencies for
project org.apache.nifi:nifi-hadoop-utils:jar:1.7.1: Cannot access actu-libs ([http://ausartprd01.opentext.net:8081/artifactory/actu-libs])
in offline mode and the artifact net.minidev:json-smart:jar:2.3 has not been downloaded from
it before. -> [Help 1]
>  I look at the cache and the jar is there and it is used previously in the build - here
are some messages
> [DEBUG]   (f) testPath = [D:\test\src\Server\nifi\nifi-nar-bundles\nifi-framework-bundle\nifi-framework-nar\target\test-classes
...., d:\test\.m2\repository\com\nimbusds\oauth2-oidc-sdk\5.34.2\oauth2-oidc-sdk-5.34.2.jar,
d:\test\.m2\repository\javax\mail\mail\1.4.7\mail-1.4.7.jar, d:\test\.m2\repository\javax\activation\activation\1.1\activation-1.1.jar,
d:\test\.m2\repository\com\github\stephenc\jcip\jcip-annotations\1.0-1\jcip-annotations-1.0-1.jar,
*d:\test\.m2\repository\net\minidev\json-smart\2.3\json-smart-2.3.jar*, d:\test\.m2\repository\net\minidev\accessors-smart\1.2\accessors-smart-1.2.jar,
d:\test\.m2\repository\org\ow2\asm\asm\5.0.4\asm-5.0.4.jar, d:\test\.m2\repository\com\nimbusds\lang-tag\1.4.3\lang-tag-1.4.3.jar,
...
> [INFO] Copying json-smart-2.3.jar to D:\test\src\Server\nifi\nifi-nar-bundles\nifi-framework-bundle\nifi-framework-nar\target\classes\META-INF\bundled-dependencies\json-smart-2.3.jar
>  
> Any ideas what is going on?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message