maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Florian Kirchmeir (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MPMD-286) JDK 12 compatibility
Date Fri, 03 May 2019 16:34:00 GMT

    [ https://issues.apache.org/jira/browse/MPMD-286?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16832642#comment-16832642
] 

Florian Kirchmeir commented on MPMD-286:
----------------------------------------

Sorry, seems to be already fixed in version 3.12.0, which is not advertised at [https://blogs.apache.org/maven/entry/apache-maven-pmd-plugin-3],
so I missed that!

> JDK 12 compatibility
> --------------------
>
>                 Key: MPMD-286
>                 URL: https://issues.apache.org/jira/browse/MPMD-286
>             Project: Maven PMD Plugin
>          Issue Type: Task
>          Components: PMD
>    Affects Versions: 3.11.0
>            Reporter: Florian Kirchmeir
>            Priority: Critical
>
> The plugin currently does not support java 12, so we get this message:
> {noformat}
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-pmd-plugin:3.11.0:pmd (pmd)
on project pwp: Execution pmd of goal org.apache.maven.plugins:maven-pmd-plugin:3.11.0:pmd
failed: org.apache.maven.reporting.MavenReportException: Unsupported targetJdk value '12'.
-> [Help 1]
> {noformat}
> See MPMD-270



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message