maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [maven-gpg-plugin] rfscholte commented on a change in pull request #3: [MGPG-71] - Plugin does not work with GPG on OSX based on MacGPG2
Date Fri, 26 Jul 2019 12:57:54 GMT
rfscholte commented on a change in pull request #3: [MGPG-71] - Plugin does not work with GPG
on OSX based on MacGPG2
URL: https://github.com/apache/maven-gpg-plugin/pull/3#discussion_r307730242
 
 

 ##########
 File path: src/test/java/org/apache/maven/plugin/gpg/GpgVersionTest.java
 ##########
 @@ -30,6 +30,7 @@ public void test()
     {
         assertTrue( GpgVersion.parse( "gpg (GnuPG) 2.2.1" ).isAtLeast( GpgVersion.parse(
"gpg (GnuPG) 2.2.1" ) ) );
         assertTrue( GpgVersion.parse( "gpg (GnuPG) 2.2.1" ).isAtLeast( GpgVersion.parse(
"2.1" ) ) );
+        assertTrue( GpgVersion.parse( "gpg (GnuPG/MacGPG2) 2.2.10" ).isAtLeast( GpgVersion.parse(
"2.2.9" ) ) );
 
 Review comment:
   Seems like I wrote some odd tests here, equals  should work too

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message