maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (MSITE-848) Maven properties with dots do not get injected into site templates
Date Fri, 02 Aug 2019 19:16:00 GMT

     [ https://issues.apache.org/jira/browse/MSITE-848?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte closed MSITE-848.
--------------------------------
    Resolution: Not A Problem
      Assignee: Robert Scholte

This is a limitation of the way Velocity parses expressions, see https://maven.apache.org/plugins/maven-site-plugin/examples/creating-content.html#Filtering

> Maven properties with dots do not get injected into site templates
> ------------------------------------------------------------------
>
>                 Key: MSITE-848
>                 URL: https://issues.apache.org/jira/browse/MSITE-848
>             Project: Maven Site Plugin
>          Issue Type: Bug
>          Components: property interpolation
>    Affects Versions: 3.8.2
>            Reporter: Christopher Tubbs
>            Assignee: Robert Scholte
>            Priority: Major
>
> I tried injecting a property from {{pom.xml}} into {{src/site/markdown/index.md.vm}}.
> It did not work when the property was {{accumulo.version}}, but did work when I switched
the property name to {{accumuloVersion}}.
> With the dot present in the property name, nothing was interpolated, and instead, I got
the literal {{${accumulo.version\}}} in my html output.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message