maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Boyles (Jira)" <j...@apache.org>
Subject [jira] [Commented] (MCOMPILER-427) Lack of guide for cross-compilation for JDK 9+
Date Thu, 10 Sep 2020 12:59:00 GMT

    [ https://issues.apache.org/jira/browse/MCOMPILER-427?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17193612#comment-17193612
] 

Michael Boyles commented on MCOMPILER-427:
------------------------------------------

You are looking at the wrong page. That page describes how to use a JDK other than the one
Maven itself is running on, not how to target a lower version while running on the same JDK.

There is already a page describing in detail what you need: [https://maven.apache.org/plugins/maven-compiler-plugin/examples/set-compiler-source-and-target.html]

It is just one below the page you linked on the sidebar. 

> Lack of guide for cross-compilation for JDK 9+
> ----------------------------------------------
>
>                 Key: MCOMPILER-427
>                 URL: https://issues.apache.org/jira/browse/MCOMPILER-427
>             Project: Maven Compiler Plugin
>          Issue Type: Improvement
>            Reporter: Peter Lee
>            Priority: Minor
>
> For JDK9+, we need the _release_ or _maven.compiler.target_ to specify the target jdk
bytecode version. But this is not stated out in the website guide page : 
> [https://maven.apache.org/plugins/maven-compiler-plugin/examples/compile-using-different-jdk.html]
> I think this should be stated here.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message