maven-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: core-it-maven-3-win #942
Date Sat, 20 Jun 2015 09:28:49 GMT
See <https://builds.apache.org/job/core-it-maven-3-win/942/changes>

Changes:

[krosenvold] Upgraded to java7 language features

------------------------------------------
[...truncated 783 lines...]
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\repository\legacy\DefaultWagonManager.java>:572:
error: diamond operator is not supported in -source 1.6
    [javac]         Map<String, ChecksumObserver> checksums = new HashMap<>( 2
);
    [javac]                                                               ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\repository\legacy\LegacyRepositorySystem.java>:161:
error: diamond operator is not supported in -source 1.6
    [javac]             List<String> exclusions = new ArrayList<>();
    [javac]                                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\repository\legacy\TransferListenerAdapter.java>:58:
error: diamond operator is not supported in -source 1.6
    [javac]         this.artifacts = new IdentityHashMap<>();
    [javac]                                              ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\repository\legacy\resolver\DefaultLegacyArtifactCollector.java>:119:
error: diamond operator is not supported in -source 1.6
    [javac]         Map<Object, List<ResolutionNode>> resolvedArtifacts = new
LinkedHashMap<>();
    [javac]                                                                              
  ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\repository\metadata\ClasspathContainer.java>:65:
error: diamond operator is not supported in -source 1.6
    [javac]             classpath = new ArrayList<>( 16 );
    [javac]                                       ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\repository\metadata\DefaultClasspathTransformation.java>:104:
error: diamond operator is not supported in -source 1.6
    [javac]             visited = new ArrayList<>( cleanGraph.getVertices().size() );
    [javac]                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\repository\metadata\DefaultGraphConflictResolver.java>:156:
error: diamond operator is not supported in -source 1.6
    [javac]         List<MetadataGraphVertex> visited = new ArrayList<>( g.getVertices().size()
);
    [javac]                                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\repository\metadata\MetadataGraph.java>:247:
error: diamond operator is not supported in -source 1.6
    [javac]             vertices = new TreeSet<>();
    [javac]                                    ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-compat\src\main\java\org\apache\maven\usability\plugin\ExpressionDocumenter.java>:53:
error: diamond operator is not supported in -source 1.6
    [javac]             expressionDocumentation = new HashMap<>();
    [javac]                                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\DefaultArtifactFilterManager.java>:63:
error: diamond operator is not supported in -source 1.6
    [javac]             excludedArtifacts = new LinkedHashSet<>( coreArtifacts );
    [javac]                                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\DefaultMaven.java>:373:
error: diamond operator is not supported in -source 1.6
    [javac]             new LinkedHashSet<>();
    [javac]                               ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\DefaultProjectDependenciesResolver.java>:94:
error: diamond operator is not supported in -source 1.6
    [javac]         Set<Artifact> resolved = new LinkedHashSet<>();
    [javac]                                                    ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\ReactorReader.java>:70:
error: diamond operator is not supported in -source 1.6
    [javac]         projectsByGA = new HashMap<>( projectsByGAV.size() * 2 );
    [javac]                                    ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\RepositoryUtils.java>:100:
error: diamond operator is not supported in -source 1.6
    [javac]         List<String> trail = new ArrayList<>( 1 );
    [javac]                                            ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\handler\manager\DefaultArtifactHandlerManager.java>:42:
error: diamond operator is not supported in -source 1.6
    [javac]     private Map<String, ArtifactHandler> unmanagedHandlers = new ConcurrentHashMap<>();
    [javac]                                                                              
     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\repository\DefaultRepositoryRequest.java>:121:
error: diamond operator is not supported in -source 1.6
    [javac]             remoteRepositories = new ArrayList<>();
    [javac]                                                ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\repository\metadata\AbstractRepositoryMetadata.java>:71:
error: multi-catch statement is not supported in -source 1.6
    [javac]         catch ( IOException | XmlPullParserException e )
    [javac]                             ^
    [javac]   (use -source 7 or higher to enable multi-catch statement)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\resolver\ArtifactResolutionRequest.java>:62:
error: diamond operator is not supported in -source 1.6
    [javac]     private List<ResolutionListener> listeners = new ArrayList<>();
    [javac]                                                                ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\resolver\ArtifactResolutionResult.java>:85:
error: diamond operator is not supported in -source 1.6
    [javac]             artifacts = new LinkedHashSet<>();
    [javac]                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\resolver\DefaultResolutionErrorHandler.java>:86:
error: diamond operator is not supported in -source 1.6
    [javac]         return ( items != null ) ? new ArrayList<>( items ) : null;
    [javac]                                                  ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\resolver\ResolutionNode.java>:67:
error: diamond operator is not supported in -source 1.6
    [javac]         parents = new ArrayList<>();
    [javac]                                 ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\resolver\filter\AndArtifactFilter.java>:42:
error: diamond operator is not supported in -source 1.6
    [javac]         this.filters = new LinkedHashSet<>();
    [javac]                                          ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\resolver\filter\CumulativeScopeArtifactFilter.java>:48:
error: diamond operator is not supported in -source 1.6
    [javac]         this.scopes = new HashSet<>();
    [javac]                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\resolver\filter\ExclusionSetFilter.java>:38:
error: diamond operator is not supported in -source 1.6
    [javac]         this.excludes = new LinkedHashSet<>( Arrays.asList( excludes ) );
    [javac]                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\artifact\resolver\filter\IncludesArtifactFilter.java>:42:
error: diamond operator is not supported in -source 1.6
    [javac]         this.patterns = new LinkedHashSet<>( patterns );
    [javac]                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\bridge\MavenRepositorySystem.java>:117:
error: diamond operator is not supported in -source 1.6
    [javac]             List<String> exclusions = new ArrayList<>();
    [javac]                                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\classrealm\DefaultClassRealmManager.java>:159:
error: diamond operator is not supported in -source 1.6
    [javac]         Set<String> artifactIds = new LinkedHashSet<>();
    [javac]                                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\eventspy\internal\EventSpyDispatcher.java>:49:
error: diamond operator is not supported in -source 1.6
    [javac]         this.eventSpies = new ArrayList<>( eventSpies );
    [javac]                                         ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\eventspy\internal\EventSpyDispatcher.java>:87:
error: multi-catch statement is not supported in -source 1.6
    [javac]             catch ( Exception | LinkageError e )
    [javac]                               ^
    [javac]   (use -source 7 or higher to enable multi-catch statement)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\exception\DefaultExceptionHandler.java>:106:
error: diamond operator is not supported in -source 1.6
    [javac]             children = new ArrayList<>();
    [javac]                                      ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\execution\DefaultMavenExecutionRequest.java>:242:
error: diamond operator is not supported in -source 1.6
    [javac]             goals = new ArrayList<>();
    [javac]                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\execution\DefaultMavenExecutionRequestPopulator.java>:72:
error: diamond operator is not supported in -source 1.6
    [javac]             Map<String, List<ToolchainModel>> groupedToolchains =
new HashMap<>( 2 );
    [javac]                                                                              
^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\execution\DefaultMavenExecutionResult.java>:41:
error: diamond operator is not supported in -source 1.6
    [javac]     private final List<Throwable> exceptions = new CopyOnWriteArrayList<>();
    [javac]                                                                         ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\execution\MavenSession.java>:77:
error: diamond operator is not supported in -source 1.6
    [javac]         new ConcurrentHashMap<>();
    [javac]                               ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\execution\ReactorManager.java>:50:
error: diamond operator is not supported in -source 1.6
    [javac]     private List<String> blackList = new ArrayList<>();
    [javac]                                                    ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\execution\SettingsAdapter.java>:107:
error: diamond operator is not supported in -source 1.6
    [javac]         List<Profile> result = new ArrayList<>();
    [javac]                                              ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\execution\scope\internal\MojoExecutionScope.java>:57:
error: diamond operator is not supported in -source 1.6
    [javac]     private final ThreadLocal<LinkedList<ScopeState>> values = new
ThreadLocal<>();
    [javac]                                                                              
 ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\extension\internal\CoreExports.java>:50:
error: diamond operator is not supported in -source 1.6
    [javac]         Map<String, ClassLoader> packages = new LinkedHashMap<>();
    [javac]                                                               ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\extension\internal\CoreExtensionEntry.java>:87:
error: diamond operator is not supported in -source 1.6
    [javac]         Set<String> artifacts = new LinkedHashSet<>();
    [javac]                                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\graph\DefaultGraphBuilder.java>:161:
error: diamond operator is not supported in -source 1.6
    [javac]             Collection<MavenProject> selectedProjects = new LinkedHashSet<>(
projects.size() );
    [javac]                                                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\graph\DefaultProjectDependencyGraph.java>:60:
error: diamond operator is not supported in -source 1.6
    [javac]         return new ArrayList<>( sorter.getSortedProjects() );
    [javac]                              ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\graph\FilteredProjectDependencyGraph.java>:77:
error: diamond operator is not supported in -source 1.6
    [javac]         return new ArrayList<>( sortedProjects );
    [javac]                              ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\internal\aether\DefaultRepositorySystemSessionFactory.java>:104:
error: diamond operator is not supported in -source 1.6
    [javac]         Map<Object, Object> configProps = new LinkedHashMap<>();
    [javac]                                                             ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\DefaultLifecycles.java>:64:
error: diamond operator is not supported in -source 1.6
    [javac]         this.lifecycles = new LinkedHashMap<>();
    [javac]                                             ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\MavenExecutionPlan.java>:68:
error: diamond operator is not supported in -source 1.6
    [javac]         lastMojoExecutionForAllPhases = new LinkedHashMap<>();
    [javac]                                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\BuildListCalculator.java>:41:
error: diamond operator is not supported in -source 1.6
    [javac]         List<ProjectSegment> projectBuilds = new ArrayList<>();
    [javac]                                                            ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\DefaultLifecycleExecutionPlanCalculator.java>:191:
error: diamond operator is not supported in -source 1.6
    [javac]         final List<MojoExecution> mojoExecutions = new ArrayList<>();
    [javac]                                                                  ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\DefaultLifecycleExecutionPlanCalculator.java>:462:
error: multi-catch statement is not supported in -source 1.6
    [javac]         catch ( IOException | XmlPullParserException e )
    [javac]                             ^
    [javac]   (use -source 7 or higher to enable multi-catch statement)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\DefaultLifecycleMappingDelegate.java>:65:
error: diamond operator is not supported in -source 1.6
    [javac]             new LinkedHashMap<>();
    [javac]                               ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\DefaultLifecyclePluginAnalyzer.java>:96:
error: diamond operator is not supported in -source 1.6
    [javac]         Map<Plugin, Plugin> plugins = new LinkedHashMap<>();
    [javac]                                                         ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\DefaultLifecycleTaskSegmentCalculator.java>:91:
error: diamond operator is not supported in -source 1.6
    [javac]         List<TaskSegment> taskSegments = new ArrayList<>( tasks.size()
);
    [javac]                                                        ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\ExecutionPlanItem.java>:53:
error: diamond operator is not supported in -source 1.6
    [javac]         List<ExecutionPlanItem> result = new ArrayList<>();
    [javac]                                                        ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\LifecycleDebugLogger.java>:158:
error: diamond operator is not supported in -source 1.6
    [javac]         Set<String> scopesToCollect = new TreeSet<>();
    [javac]                                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\LifecycleDependencyResolver.java>:132:
error: diamond operator is not supported in -source 1.6
    [javac]             Map<String, Artifact> map = new HashMap<>();
    [javac]                                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\LifecyclePluginResolver.java>:62:
error: diamond operator is not supported in -source 1.6
    [javac]         Map<String, String> versions = new HashMap<>( 64 );
    [javac]                                                    ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\MojoDescriptorCreator.java>:299:
error: diamond operator is not supported in -source 1.6
    [javac]             plugin.setDependencies( new ArrayList<>( pluginInPom.getDependencies()
) );
    [javac]                                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\MojoExecutor.java>:84:
error: diamond operator is not supported in -source 1.6
    [javac]         Set<String> scopesToCollect = new TreeSet<>();
    [javac]                                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\MojoExecutor.java>:209:
error: multi-catch statement is not supported in -source 1.6
    [javac]             catch ( MojoFailureException | PluginManagerException | PluginConfigurationException
    [javac]                                          ^
    [javac]   (use -source 7 or higher to enable multi-catch statement)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\ProjectBuildList.java>:62:
error: diamond operator is not supported in -source 1.6
    [javac]         List<ProjectSegment> currentSegment = new ArrayList<>();
    [javac]                                                             ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] <https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\maven-core\src\main\java\org\apache\maven\lifecycle\internal\ProjectIndex.java>:48:
error: diamond operator is not supported in -source 1.6
    [javac]         this.projects = new HashMap<>( projects.size() * 2 );
    [javac]                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] 100 errors
    [javac] 1 warning

BUILD FAILED
<https://builds.apache.org/job/core-it-maven-3-win/ws/maven-3-trunk\build.xml>:227:
Compile failed; see the compiler error output for details.

Total time: 1 minute 19 seconds
Build step 'Invoke Ant' marked build as failure
Recording test results

Mime
View raw message