maven-wagon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Serodio <nabble.dsero...@neverbox.com>
Subject What's happened to wagon's sshExecutable setting?
Date Wed, 09 Sep 2009 20:09:48 GMT

I'm on Windows XP, and I'm trying to make Maven deployment use my private key
which is stored in PuTTY's Pageant ssh agent.

I found an old recipe on the net that says I should use the following
settings.xml:

<server>
    <id>my-repo</id>
    <configuration>
        <sshExecutable>c:/Progra~1/PuTTY/plink.exe</sshExecutable>
        <scpExecutable>c:/Progra~1/PuTTY/pscp.exe</scpExecutable>
    </configuration>
</server>

But when I try this, I get the following error:

[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error retrieving previous build number for artifact
'br.pucsp.apt:ereinion:jar': repository metadata for: 'snapshot
br.pucsp.apt:ereinion:2.0.0-SNAPSHOT'
 could not be retrieved from repository: vulcano-repo due to an error: While
configuring wagon for 'vulcano-repo': Unable to apply wagon configuration.

Cannot find setter nor field in
org.apache.maven.wagon.providers.ssh.jsch.ScpWagon for 'sshExecutable'
-- 
View this message in context: http://www.nabble.com/What%27s-happened-to-wagon%27s-sshExecutable-setting--tp25372367p25372367.html
Sent from the Wagon - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: wagon-users-unsubscribe@maven.apache.org
For additional commands, e-mail: wagon-users-help@maven.apache.org


Mime
View raw message