mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Klues <>
Subject Re: Review Request 44360: Added a script to install the Nvidia GDK on a host.
Date Mon, 14 Mar 2016 00:25:22 GMT

This is an automatically generated e-mail. To reply, visit:

(Updated March 14, 2016, 12:25 a.m.)

Review request for mesos, Ben Mahler, Rob Todd, and Vikrama Ditya.


Addressed all of klaus1982 and bmahler's comment.

Bugs: MESOS-4860

Repository: mesos

Description (updated)

This script can be used to install the Nvidia GPU Deployment Kit (GDK)
on a mesos development machine. The purpose of the GDK is to provide
stubs for compiling code against Nvidia's latest drivers.  It includes
all the necessary header files (nvml.h) and library files
( necessary to build mesos with Nvidia GPU support.
However, it does not actually contain any driver code, and it can't be
used to interact with any GPUs installed on a system. For that, you
will have to find the latest released drivers themselves.

We provide this script only for convenience, so that developers
working on non-GPU equipped systems can build code with Nvidia GPU
support. It is a simple wrapper around the official GDK installer
script provided by Nvidia, which can be downloaded here:

The script itself takes a few parameters. Run it as
'support/ --help' to see its usage semantics.

Diffs (updated)

  support/ PRE-CREATION 


Testing (updated)

I ran the script on my Mac to verify that it fails out cleanly.

I ran it on a linux box to exercise each of the different flags that can be passed to it.
``` --install-dir=<root_directory> --install-dir=<non_root_directory> --install-dir=<root_directory> --update-ldcache --install-dir=<non_root_directory> --update-ldcache

With each combination, I verified that the proper error messages were reported, or that the
installation was successful.

As per one of the comments below, I also temporarily changed the download URL for the installer
to make sure that the `wget` call errored out cleanly.


Kevin Klues

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message