mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Chung <cinchu...@gmail.com>
Subject Re: Review Request 67413: Refactored logic for `PYTHON` and `PYTHON_VERSION` in `configure.ac`.
Date Wed, 04 Jul 2018 07:08:00 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/67413/#review205710
-----------------------------------------------------------


Ship it!




Ship It!

- Eric Chung


On July 3, 2018, 2:40 p.m., Armand Grillet wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/67413/
> -----------------------------------------------------------
> 
> (Updated July 3, 2018, 2:40 p.m.)
> 
> 
> Review request for mesos, Andrew Schwartzmeyer, Benjamin Bannier, Eric Chung, and Kevin
Klues.
> 
> 
> Bugs: MESOS-8955
>     https://issues.apache.org/jira/browse/MESOS-8955
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This will facilitate the introduction of `PYTHON_3` and
> `PYTHON_3_VERSION` to build the CLI in a future commit.
> 
> 
> Diffs
> -----
> 
>   configure.ac 8b8064aca7ae39e16dda40828b5a087b14b54a65 
> 
> 
> Diff: https://reviews.apache.org/r/67413/diff/9/
> 
> 
> Testing
> -------
> 
> My machine runs Python 2 when using `python` but `python3` is available. The result of
`configure` was:
> 
> `../configure` works.
> `PYTHON_VERSION=3 ../configure` returns `configure: error: Mesos requires Python <
3.0`.
> `PYTHON=python3 ../configure` returns `configure: error: Mesos requires Python < 3.0`.
> `PYTHON=python3 ../configure --disable-python` works.
> `PYTHON=python3 ../configure --disable-python --enable-new-cli` returns `configure: error:
Mesos requires Python < 3.0`.
> 
> 
> Thanks,
> 
> Armand Grillet
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message