metron-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nickwallen <>
Subject [GitHub] incubator-metron issue #145: METRON-212: Allow additional Elasticsearch temp...
Date Wed, 08 Jun 2016 12:34:08 GMT
Github user nickwallen commented on the issue:
    It would be nice for the new role names in METRON-211 and METRON-212 to be consistent.
 Which naming convention makes more sense?
    - METRON-211 convention -> metron_kafka, metron_hbase, metron_elasticsearch
    - METRON-212 convention -> elasticsearch_templates, kafka_topics, hbase_tables
    The reasons I like the METRON-211 convention slightly better is that:
    1. The role names include `metron` indicating that the role specifically affects the deployment
of core Metron.
    2. The names center around a core Hadoop-y service so that, for example, if we need to
add additional functionality that impacts Elasticsearch we can throw it into the same `metron_elasticsearch`
role and the name still makes sense.
    I could certainly be persuaded that METRON-212 is better though.  If that is the case,
I will update the names in METRON-211.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

View raw message