metron-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tyler Moore <tmo...@goflyball.com>
Subject Re: Kafka error when upgrading to Metron 0.3.0
Date Mon, 09 Jan 2017 04:55:51 GMT
Michael,

I am receiving error when trying to build with HPD profile, have you had
any problems with pcap-backend tests failing when building with hdp profile?
Errors and log files provided below:

Results :

Failed tests:

PcapTopologyIntegrationTest.testTimestampInKey:152->testTopology:388->assertInOrder:542
null

PcapTopologyIntegrationTest.testTimestampInPacket:135->testTopology:388->assertInOrder:542
null



Tests run: 2, Failures: 2, Errors: 0, Skipped: 0

[INFO]
------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] Metron ............................................. SUCCESS [
 0.639 s]
[INFO] metron-analytics ................................... SUCCESS [
 0.029 s]
[INFO] metron-maas-common ................................. SUCCESS [
 8.771 s]
[INFO] metron-platform .................................... SUCCESS [
 0.057 s]
[INFO] metron-test-utilities .............................. SUCCESS [
 0.976 s]
[INFO] metron-integration-test ............................ SUCCESS [
 3.888 s]
[INFO] metron-maas-service ................................ SUCCESS [01:19
min]
[INFO] metron-common ...................................... SUCCESS [
41.718 s]
[INFO] metron-statistics .................................. SUCCESS [
30.713 s]
[INFO] metron-hbase ....................................... SUCCESS [
37.286 s]
[INFO] metron-profiler-common ............................. SUCCESS [
 7.967 s]
[INFO] metron-profiler-client ............................. SUCCESS [
54.088 s]
[INFO] metron-profiler .................................... SUCCESS [02:28
min]
[INFO] metron-writer ...................................... SUCCESS [
 7.151 s]
[INFO] metron-enrichment .................................. SUCCESS [
57.076 s]
[INFO] metron-indexing .................................... SUCCESS [
 7.028 s]
[INFO] metron-solr ........................................ SUCCESS [
36.695 s]
[INFO] metron-pcap ........................................ SUCCESS [
 1.123 s]
[INFO] metron-parsers ..................................... SUCCESS [01:58
min]
[INFO] metron-pcap-backend ................................ FAILURE [
49.928 s]
[INFO] metron-data-management ............................. SKIPPED
[INFO] metron-api ......................................... SKIPPED
[INFO] metron-management .................................. SKIPPED
[INFO] elasticsearch-shaded ............................... SKIPPED
[INFO] metron-elasticsearch ............................... SKIPPED
[INFO] metron-deployment .................................. SKIPPED
[INFO] Metron Ambari Management Pack ...................... SKIPPED
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 11:31 min
[INFO] Finished at: 2017-01-08T22:23:59-05:00
[INFO] Final Memory: 287M/6202M
[INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-surefire-plugin:2.18:test
(integration-tests) on project metron-pcap-backend: There are test failures.


Regards,

Tyler Moore
Software Engineer
Phone: 248-909-2769
Email: moore.tyler@goflyball.com


On Thu, Jan 5, 2017 at 5:21 PM, Michael Miklavcic <
michael.miklavcic@gmail.com> wrote:

> Hey Tyler,
>
> Build Metron with the HDP profile to get the proper deps for this
> -PHDP-2.5.0.0
>
> Hopefully that works for you.
>
> Best,
> Mike
>
>
> On Thu, Jan 5, 2017 at 3:17 PM, Tyler Moore <tmoore@goflyball.com> wrote:
>
> > Hey all,
> >
> > Wondering if there is a solution to the "Offset lags for kafka not
> > supported for older versions. Please update kafka spout to latest
> version."
> > error seen when upgrading to metron 0.3.0?
> >
> > I know it is due to kafka-storm dependency that needs updated, but what
> is
> > the best way to go about that? Is it as simple at changing the version in
> > the metron pom.xml and provisioning?
> >
> > Regards,
> >
> > Tyler Moore
> > Software Engineer
> > Phone: 248-909-2769
> > Email: moore.tyler@goflyball.com
> >
>

Mime
View raw message