metron-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mmiklavc <...@git.apache.org>
Subject [GitHub] metron issue #530: METRON-777 Metron Extension System and Parser Extensions
Date Thu, 29 Jun 2017 21:50:20 GMT
Github user mmiklavc commented on the issue:

    https://github.com/apache/metron/pull/530
  
    @ottobackwards removing the extra project element allows me to build the project now.
However, I'm still unable to use the archetype. It neither shows up in the local catalog listing
nor allows me to enter the info directly. It fails in both cases, even though the archetype
is now appearing in `~/.m2/repository/archetype-catalog.xml`. Per the Maven docs for the archetype
plugin, the entries should be in `~/.m2/archetype-catalog.xml`. - https://maven.apache.org/archetype/maven-archetype-plugin/specification/archetype-catalog.html.
    
    The only thing I could do to get this working was to explicitly update the local catalog
with the archetype plugin, which doesn't make any sense to me seeing as this is by default
tied to the install goal in the first place.
    
    There are 2 archetype-catalog.xml files locally with Maven and I'm unclear as to why.
The only difference appears to be that 1) only ~/.m2/archetype-catalog.xml entries show up
when you run `mvn archetype:generate -DarchetypeCatalog=local` and 2) non-SNAPSHOT entries
end up in `~/.m2/archetype-catalog.xml` whereas SNAPSHOT entries end up in `~/.m2/repository/archetype-catalog.xml`.
    
    ```
    cat ~/.m2/repository/archetype-catalog.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <archetype-catalog xsi:schemaLocation="http://maven.apache.org/plugins/maven-archetype-plugin/archetype-catalog/1.0.0
http://maven.apache.org/xsd/archetype-catalog-1.0.0.xsd"
        xmlns="http://maven.apache.org/plugins/maven-archetype-plugin/archetype-catalog/1.0.0"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <archetypes>
        <archetype>
          <groupId>org.apache.metron</groupId>
          <artifactId>metron-maven-parser-extension-archetype</artifactId>
          <version>0.4.0</version>
          <description>Apache Maven Parser Extension Archetype for Metron</description>
        </archetype>
      </archetypes>
    </archetype-catalog>
    ```
    When I run `mvn archetype:update-local-catalog` the entry appears in ~/.m2/archetype-catalog.xml.
If I delete the entry and re-run that command, the entry reappears. Now when I run the archetype:generate
command, the Metron archetype appears as expected. Is anyone else seeing this behavior? This
does not happen for me when I install and attempt to use other archetypes, e.g. https://github.com/mmiklavc/hadoop-bootstrap-archetype

    
    Here's the output, as desired, after the archetype is added to the correct archetype-catalog.xml
    
    ```
    [INFO] No archetype defined. Using maven-archetype-quickstart (org.apache.maven.archetypes:maven-archetype-quickstart:1.0)
    Choose archetype:
    ...
    4: local -> com.michaelmiklavcic:hadoop-bootstrap-archetype (Archetype - hadoop-bootstrap-archetype)
    5: local -> org.apache.metron:metron-maven-archetypes (Apache Maven Archetypes for
Metron)
    ```


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message