metron-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anandsubbu <...@git.apache.org>
Subject [GitHub] metron issue #841: METRON-1316 Fastcapa Fails to Compile in Test Environment
Date Tue, 21 Nov 2017 06:17:01 GMT
Github user anandsubbu commented on the issue:

    https://github.com/apache/metron/pull/841
  
    Hi @nickwallen 
    
    > I am not sure exactly what the problem is, but the same condition occurs in master.
I would call this a pre-existing condition that we can handle with a separate PR.
    > 
    > Of course that is just my opinion and you or others may feel differently. Let me
know what you think.
    > 
    
    Sure, I am fine by it, since I did not see any anomalies due to this error.
    
    Also, I was trying to test the same with CentOS 7.4 image and ran into some challenges.
I am constantly facing a 'Timed out' issue when attempting 'vagrant up' on my local system.

    
    ```
    ➜  centos-7.4 git:(master) ✗ vagrant up
    Bringing machine 'source' up with 'virtualbox' provider...
    Bringing machine 'sink' up with 'virtualbox' provider...
    ==> source: Box 'bento/centos-7.4' could not be found. Attempting to find and install...
        source: Box Provider: virtualbox
        source: Box Version: >= 0
    ==> source: Loading metadata for box 'bento/centos-7.4'
        source: URL: https://atlas.hashicorp.com/bento/centos-7.4
    ==> source: Adding box 'bento/centos-7.4' (v201710.25.0) for provider: virtualbox
        source: Downloading: https://vagrantcloud.com/bento/boxes/centos-7.4/versions/201710.25.0/providers/virtualbox.box
    ==> source: Box download is resuming from prior download progress
    ==> source: Successfully added box 'bento/centos-7.4' (v201710.25.0) for 'virtualbox'!
    ==> source: Importing base box 'bento/centos-7.4'...
    ==> source: Matching MAC address for NAT networking...
    ==> source: Checking if box 'bento/centos-7.4' is up to date...
    ==> source: Setting the name of the VM: centos-74_source_1511196258710_55009
    ==> source: Clearing any previously set network interfaces...
    ==> source: Preparing network interfaces based on configuration...
        source: Adapter 1: nat
        source: Adapter 2: hostonly
    ==> source: Forwarding ports...
        source: 22 (guest) => 2222 (host) (adapter 1)
    ==> source: Running 'pre-boot' VM customizations...
    ==> source: Booting VM...
    ==> source: Waiting for machine to boot. This may take a few minutes...
        source: SSH address: 127.0.0.1:2222
        source: SSH username: vagrant
        source: SSH auth method: private key
    Timed out while waiting for the machine to boot. This means that
    Vagrant was unable to communicate with the guest machine within
    the configured ("config.vm.boot_timeout" value) time period.
    If you look above, you should be able to see the error(s) that
    Vagrant had when attempting to connect to the machine. These errors
    are usually good hints as to what may be wrong.
    If you're using a custom box, make sure that networking is properly
    working and you're able to connect to the machine. It is a common
    problem that networking isn't setup properly in these boxes.
    Verify that authentication configurations are also setup properly,
    as well.
    If the box appears to be booting properly, you may want to increase
    the timeout ("config.vm.boot_timeout") value.
    ➜  centos-7.4 git:(master) ✗ vagrant status
    Current machine states:
    source                    running (virtualbox)
    sink                      not created (virtualbox)
    
    ```
    
    I did a fresh import of the 'bento/centos-7.4' box image multiple times after cleaning
up (`vagrant box remove bento/centos-7.4` followed by fresh import), but I ran into the same
timeout issue. Also tried bumping up `config.vm.boot_timeout` in `Vagrantfile` to 600, but
to no avail.
    
    Further I am also not able to vagrant ssh into the 'source' VM despite it showing as running.

    
    Does it look like I missed something in my configuration? 


---

Mime
View raw message