metron-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cestella <>
Subject [GitHub] metron issue #831: METRON-1302: Split up Indexing Topology into batch and ra...
Date Thu, 04 Jan 2018 17:30:51 GMT
Github user cestella commented on the issue:
    Ok, I thought the general consensus was different.  As per my comment:
    That sounds good. Which one would you guys prefer:
    * display names in the mpack of "Elasticsearch" and "HDFS"
    * variable prefixes of es and hdfs
    I think I'd prefer the first as I really have been trying to set us up to a world where
we can make things pluggable (this is the first baby step).
    Nobody commented on that, so I went with adjusting the display names rather than variable
prefixes.  The reason why I preferred to do that was that when we do a better job of including
Solr or other indices, prefixing the variables `elasticsearch` will be confusing.  The flux
files are generic to the writer type for the random access indices.  I can understand the
confusion for the user given we only really support HDFS and elasticsearch right now, which
is why I changed the display names.
    Can we recap the reasons against this approach?


View raw message