mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From peter royal <pro...@apache.org>
Subject Re: ReferenceCountingIoFilter vs ReferenceCountingIoFilterWrapper (Was: Re: svn commit: r411055 - in /directory/trunks/mina/core/src/main/java/org/apache/mina/common: IoFilter.java ReferenceCountingIoFilter.java ReferenceCountingIoFilterWrapper.java)
Date Wed, 14 Jun 2006 13:57:40 GMT
On Jun 4, 2006, at 3:53 AM, Trustin Lee wrote:
> On 6/3/06, peter royal <proyal@apache.org> wrote:
>>
>> On Jun 2, 2006, at 1:57 AM, trustin@apache.org wrote:
>> > * Renamed ReferenceCountingIoFilterWrapper to
>> > ReferenceCountingIoFilter
>>
>> Do we not want to call it a *Wrapper or *Decorator to indicate that
>> it is a filter that will wrap another filter? I've always been in
>> favor of doing that to make the usage of a class clear from its  
>> name...
>
>
> Did we discussed about this naming scheme before?  Please blame my  
> brain if
> so. :)
>
> I just thought that it is OK to omit the name of the pattern  
> because we have
> JavaDoc that can explain what it does in one sentence.  It is  
> because using
> the class means that we know what it does.  From the readibiliy  
> viewpoint,
> we can easily guess that it's a wrapper or a decorator because there's
> another filter as a constructor parameter.  So I think it's fine to  
> omit
> Wrapper or Decorator in class names.
>
> But this is only my opinion.  Let's discuss enough to get to the  
> concensus.

Anyone else have an opinion? (If no-one does, we can leave as-is..)
-pete

-- 
proyal@apache.org - http://fotap.org/~osi



Mime
View raw message