mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niklas Therning <nik...@trillian.se>
Subject Re: jarfile help needed
Date Wed, 14 Jun 2006 12:07:49 GMT
>From Sun's docs for the -jar option:

"When you use this option, the JAR file is the source of all user
classes, and other user class path settings are ignored."

So it seems like the -cp option is ignored. Have you tried specifying
the class path in the manifest file?

Manifest-Version: 1.0
Class-Path: mina-core-0.9.4.jar
Main-Class: com.example.Main

Note that the jars you specify like this are read from the file system,
not from within the jar. As long as mina-core-0.9.4.jar is in the same
directory as mina-core-0.9.4.jar I think it should work.


Niklas Therning
Software Architect

Thor Wehage wrote:
> Hi MINA folks.
> This is probably a noob question, but i'll try anyway:
> I have built this game socketserver, and everything is fine when running
> it from Eclipse, but then I wanted to try it out IRL. So now I have put
> it on a Linux server, and this is where I get problems..
> I can't make my app "see" what's inside the mina-core jarfile, and i
> consequently get
> /Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/mina/common/IoAcceptor/
> I have tried a lot of different ways of starting it, but nothing seems
> to work.. this is my latest attempt :
> /java -jar MinaSocketserver.jar -cp mina-core-0.9.4.jar/
> Both Jar files are in the same directory on the server.
> Best regards
> Thor Wehage

View raw message