mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thor Wehage <t...@titoonic.dk>
Subject Re: jarfile help needed
Date Thu, 15 Jun 2006 06:46:28 GMT
Thank you for the help. It made me realize what I was doing wrong :-)

In stead of specifying the classpath in the manifest file, I solved the 
problem in the following manner :

java -cp mina-core-0.9.4.jar:MinaSocketserver.jar titoonic.Main
 
Best regards
Thor Wehage

Niklas Therning skrev:
> >From Sun's docs for the -jar option:
>
> "When you use this option, the JAR file is the source of all user
> classes, and other user class path settings are ignored."
>
> So it seems like the -cp option is ignored. Have you tried specifying
> the class path in the manifest file?
>
> Manifest-Version: 1.0
> Class-Path: mina-core-0.9.4.jar
> Main-Class: com.example.Main
>
> Note that the jars you specify like this are read from the file system,
> not from within the jar. As long as mina-core-0.9.4.jar is in the same
> directory as mina-core-0.9.4.jar I think it should work.
>
> HTH
>
>   

Mime
View raw message