mina-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From peter royal <pro...@apache.org>
Subject Re: svn commit: r417502 - /directory/trunks/mina/core/src/main/java/org/apache/mina/filter/ReadThrottleFilter.java
Date Tue, 04 Jul 2006 21:05:59 GMT
On Jul 3, 2006, at 4:48 AM, Trustin Lee wrote:
> * The class name ends with 'Filter', but it's not a filter.   
> Wouldn't there
> be a better name?  This is very close to IoFilterChainBuilder, but  
> it's too
> long.  Any idea?

renamed to ReadThrottleFilterBuilder

> * We have to increate the counter by remaining() instead of capacity 
> () to be
> more accurate.


> * Is it impossible to use getTrafficMask() instead of using the  
> session
> attribute?  Was there any reason to do so?

I use the session attribute so that the filter can keep track of if  
its the one that disabled reads.. but looking back at the logic I  
have, it seems like it might be superfluous.. but it just felt safe  
to have it in there :)


proyal@apache.org - http://fotap.org/~osi

View raw message